summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2016-08-24 14:26:41 +0200
committerBruno Pagani2016-08-24 14:26:41 +0200
commit2d49218107f79a45b66e7d75583eb751fba33415 (patch)
treed7f59236c733692c3a3bdc1872eb52db97ba5b48
downloadaur-2d49218107f79a45b66e7d75583eb751fba33415.tar.gz
Initial upload: mpd-server-minimal 0.19.19-1
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD106
-rw-r--r--mpd.conf6
-rw-r--r--mpd.install5
-rw-r--r--mpd.tmpfile1
5 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cfcce4c146f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = mpd-server
+ pkgdesc = Flexible, powerful, server-side application for playing music. Minimal version with only flac playback as server running under mpd user.
+ pkgver = 0.19.19
+ pkgrel = 1
+ url = http://www.musicpd.org/
+ install = mpd.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ makedepends = boost
+ depends = alsa-lib
+ depends = flac
+ depends = glib2
+ depends = icu
+ depends = libmpdclient
+ depends = sqlite
+ provides = mpd=0.19.19
+ conflicts = mpd
+ replaces = mpd
+ backup = etc/mpd.conf
+ source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.19.tar.xz
+ source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.19.tar.xz.sig
+ source = mpd.tmpfile
+ source = mpd.conf
+ validpgpkeys = 0392335A78083894A4301C43236E8A58C6DB4512
+ sha1sums = 8c281b823825cab6677cb142b564acbf09a2874d
+ sha1sums = SKIP
+ sha1sums = f4d5922abb69abb739542d8e93f4dfd748acdad7
+ sha1sums = 291fd5cda9f0845834a553017327c4586bd853f6
+
+pkgname = mpd-server-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..083e5a7743ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,106 @@
+# Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani@gmail.com>
+
+pkgbase=mpd-server
+pkgname=mpd-server-minimal
+pkgver=0.19.19
+pkgrel=1
+pkgdesc='Flexible, powerful, server-side application for playing music. Minimal version with only flac playback as server running under mpd user.'
+url='http://www.musicpd.org/'
+license=('GPL')
+arch=('i686' 'x86_64' 'armv7h')
+depends=('alsa-lib' 'flac' 'glib2' 'icu' 'libmpdclient' 'sqlite')
+makedepends=('boost')
+provides=("mpd=$pkgver")
+conflicts=('mpd')
+replaces=('mpd')
+validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512')
+source=("http://www.musicpd.org/download/mpd/${pkgver%.*}/mpd-${pkgver}.tar.xz"{,.sig}
+ 'mpd.tmpfile'
+ 'mpd.conf')
+sha1sums=('8c281b823825cab6677cb142b564acbf09a2874d'
+ 'SKIP'
+ 'f4d5922abb69abb739542d8e93f4dfd748acdad7'
+ '291fd5cda9f0845834a553017327c4586bd853f6')
+backup=('etc/mpd.conf')
+install=mpd.install
+
+build() {
+ cd "${srcdir}/mpd-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-libmpdclient \
+ --disable-ao \
+ --disable-httpd-output \
+ --disable-jack \
+ --disable-openal \
+ --disable-oss \
+ --disable-pulse \
+ --disable-recorder-output \
+ --disable-roar \
+ --disable-shout \
+ --disable-aac \
+ --disable-adplug \
+ --disable-audiofile \
+ --disable-ffmpeg \
+ --enable-flac \
+ --disable-fluidsynth \
+ --disable-gme \
+ --disable-mad \
+ --disable-mikmod \
+ --disable-modplug \
+ --disable-mpc \
+ --disable-mpg123 \
+ --disable-opus \
+ --disable-sidplay \
+ --disable-sndfile \
+ --disable-vorbis \
+ --disable-wavpack \
+ --disable-wildmidi \
+ --disable-curl \
+ --disable-expat \
+ --enable-ipv6 \
+ --disable-libwrap \
+ --disable-mms \
+ --disable-nfs \
+ --disable-smbclient \
+ --disable-soundcloud \
+ --enable-tcp \
+ --disable-upnp \
+ --disable-bzip2 \
+ --disable-iso9660 \
+ --disable-zlib \
+ --disable-zzip \
+ --disable-cdio-paranoia \
+ --disable-id3 \
+ --disable-largefile \
+ --disable-lsr \
+ --disable-soxr \
+ --disable-lame-encoder \
+ --disable-shine-encoder \
+ --disable-twolame-encoder \
+ --disable-vorbis-encoder \
+ --disable-wave-encoder \
+ --disable-neighbor-plugins \
+ --enable-sqlite \
+ --disable-systemd-daemon \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --with-zeroconf=no
+
+ make
+}
+
+package_mpd-server-minimal() {
+ cd "${srcdir}/mpd-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 ../mpd.conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 ../mpd.tmpfile "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd/{,playlists}
+
+ install -Dm644 "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+ sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+ sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+}
diff --git a/mpd.conf b/mpd.conf
new file mode 100644
index 000000000000..da7d6fae92eb
--- /dev/null
+++ b/mpd.conf
@@ -0,0 +1,6 @@
+# See: /usr/share/doc/mpd/mpdconf.example
+
+pid_file "/run/mpd/mpd.pid"
+db_file "/var/lib/mpd/mpd.db"
+state_file "/var/lib/mpd/mpdstate"
+playlist_directory "/var/lib/mpd/playlists"
diff --git a/mpd.install b/mpd.install
new file mode 100644
index 000000000000..cffab46a814e
--- /dev/null
+++ b/mpd.install
@@ -0,0 +1,5 @@
+post_install() {
+ getent group mpd &>/dev/null || groupadd -r -g 45 mpd >/dev/null
+ getent passwd mpd &>/dev/null || useradd -r -u 45 -g mpd -d /var/lib/mpd -s /bin/false -G audio mpd >/dev/null
+ usr/bin/systemd-tmpfiles --create mpd.conf || true
+}
diff --git a/mpd.tmpfile b/mpd.tmpfile
new file mode 100644
index 000000000000..41c4e743a3a1
--- /dev/null
+++ b/mpd.tmpfile
@@ -0,0 +1 @@
+d /run/mpd 0755 mpd mpd