summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Beck2018-08-29 18:21:14 -0500
committerMax Beck2018-08-29 18:21:14 -0500
commit2e54d21cfd28dd79cd578ce0fe93470d2b6238c4 (patch)
treef2fbcc02a58c0034baa2b20d080f757fc5b12f12
parent786717fe3e8397400dec0083a9fe162daa155586 (diff)
downloadaur-2e54d21cfd28dd79cd578ce0fe93470d2b6238c4.tar.gz
0.20.21
does not require configure.ac patch anymore
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD53
-rw-r--r--no_resid_builder.patch10
3 files changed, 48 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fddebf50c93a..2d70b12b5e5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mpd-sidplay
pkgdesc = Flexible, powerful, server-side application for playing music - built with sidplay support
- pkgver = 0.20.20
- pkgrel = 3
+ pkgver = 0.20.21
+ pkgrel = 1
url = https://www.musicpd.org/
arch = x86_64
license = GPL
@@ -33,23 +33,21 @@ pkgbase = mpd-sidplay
depends = zziplib
depends = libsystemd
depends = libsidplayfp
- provides = mpd=0.20.20
+ provides = mpd=0.20.21
conflicts = mpd
replaces = mpd
backup = etc/mpd.conf
- source = https://www.musicpd.org/download/mpd/0.20/mpd-0.20.20.tar.xz
- source = https://www.musicpd.org/download/mpd/0.20/mpd-0.20.20.tar.xz.sig
+ source = https://www.musicpd.org/download/mpd/0.20/mpd-0.20.21.tar.xz
+ source = https://www.musicpd.org/download/mpd/0.20/mpd-0.20.21.tar.xz.sig
source = tmpfiles.d
source = sysusers.d
source = mpd.conf
- source = no_resid_builder.patch
validpgpkeys = 0392335A78083894A4301C43236E8A58C6DB4512
- sha256sums = a9e458c6e07cdf62649de7722e1e5a7f13aa82eeb397bfbbebc07cf5cf273584
+ sha256sums = 8322764dc265c20f05c8c8fdfdd578b0722e74626bef56fcd8eebfb01acc58dc
sha256sums = SKIP
sha256sums = e09e38ab5fd6e8b3b3e6e5a48d837c164ad37aec7e6762a78810c34fe9abf3a1
sha256sums = 2679014448e9352e20e85d8d76b021aeebe27bdf6100b24577afee2f37522a95
sha256sums = a30c2c43824b540300cc83505c146989b415189bd90f191aebaed6f13556e6d2
- sha256sums = 1ad209f027670ecaf5dd3a0c9daf9cf7758ab266090a1e4cf0caf226ee9b42ed
pkgname = mpd-sidplay
diff --git a/PKGBUILD b/PKGBUILD
index 5c0e8346caa0..802eddf65637 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,59 @@
# Maintainer: Max Beck <rytonemail@gmail.com>
pkgname=mpd-sidplay
_pkgname=mpd
-pkgver=0.20.20
-_majorver=0.20
-pkgrel=3
+pkgver=0.20.21
+pkgrel=1
pkgdesc="Flexible, powerful, server-side application for playing music - built with sidplay support"
url="https://www.musicpd.org/"
license=("GPL")
arch=("x86_64")
-depends=("libao" "ffmpeg" "libmodplug" "audiofile" "libshout" "libmad" "curl" "faad2" "sqlite" "jack" "libmms" "wavpack" "avahi" "libid3tag" "yajl" "libmpdclient" "icu" "libupnp" "libnfs" "libsamplerate" "libsoxr" "smbclient" "libgme" "zziplib" "libsystemd" "libsidplayfp")
+depends=(
+ "libao"
+ "ffmpeg"
+ "libmodplug"
+ "audiofile"
+ "libshout"
+ "libmad"
+ "curl"
+ "faad2"
+ "sqlite"
+ "jack"
+ "libmms"
+ "wavpack"
+ "avahi"
+ "libid3tag"
+ "yajl"
+ "libmpdclient"
+ "icu"
+ "libupnp"
+ "libnfs"
+ "libsamplerate"
+ "libsoxr"
+ "smbclient"
+ "libgme"
+ "zziplib"
+ "libsystemd"
+ "libsidplayfp"
+)
makedepends=("boost" "doxygen")
validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512')
provides=("mpd=$pkgver")
conflicts=("mpd")
replaces=("mpd")
-source=("https://www.musicpd.org/download/${_pkgname}/${_majorver}/${_pkgname}-${pkgver}.tar.xz"{,.sig} "tmpfiles.d" "sysusers.d" "mpd.conf" "no_resid_builder.patch")
-sha256sums=("a9e458c6e07cdf62649de7722e1e5a7f13aa82eeb397bfbbebc07cf5cf273584" "SKIP" "e09e38ab5fd6e8b3b3e6e5a48d837c164ad37aec7e6762a78810c34fe9abf3a1" "2679014448e9352e20e85d8d76b021aeebe27bdf6100b24577afee2f37522a95" "a30c2c43824b540300cc83505c146989b415189bd90f191aebaed6f13556e6d2" "1ad209f027670ecaf5dd3a0c9daf9cf7758ab266090a1e4cf0caf226ee9b42ed")
+source=(
+ "https://www.musicpd.org/download/${_pkgname}/${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz"{,.sig}
+ "tmpfiles.d"
+ "sysusers.d"
+ "mpd.conf"
+)
+sha256sums=(
+ "8322764dc265c20f05c8c8fdfdd578b0722e74626bef56fcd8eebfb01acc58dc" "SKIP"
+ "e09e38ab5fd6e8b3b3e6e5a48d837c164ad37aec7e6762a78810c34fe9abf3a1"
+ "2679014448e9352e20e85d8d76b021aeebe27bdf6100b24577afee2f37522a95"
+ "a30c2c43824b540300cc83505c146989b415189bd90f191aebaed6f13556e6d2"
+)
backup=("etc/mpd.conf")
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch < ../no_resid_builder.patch
-}
-
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
./configure \
diff --git a/no_resid_builder.patch b/no_resid_builder.patch
deleted file mode 100644
index 865a6a02b121..000000000000
--- a/no_resid_builder.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.ac.old 2018-05-13 08:31:04.000000000 -0500
-+++ configure.ac 2018-05-30 17:58:54.165666666 -0500
-@@ -1017,7 +1017,6 @@
- fi
-
- if test x$enable_sidplay = xyes; then
-- SIDPLAY_LIBS="$SIDPLAY_LIBS -lresid-builder"
- AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])
- if test x$found_sidplayfp = xyes; then
- AC_DEFINE(HAVE_SIDPLAYFP, 1, [Define if libsidplayfp is used instead of libsidplay2])