summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcnmx2019-02-15 11:32:47 -0800
committerarcnmx2019-02-15 12:06:31 -0800
commit393dc87883b7d3855255489bb9306fc9d8f5d48a (patch)
treea00593fa9b6a1e5e3bdddcdc7c27616fd0bf73df
downloadaur-393dc87883b7d3855255489bb9306fc9d8f5d48a.tar.gz
0.21.4
-rw-r--r--.SRCINFO62
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD77
-rw-r--r--conf6
-rw-r--r--sysusers.d2
-rw-r--r--tmpfiles.d3
6 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdb092ac7300
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,62 @@
+pkgbase = mpd-youtube-dl
+ pkgdesc = mpd fork with youtube support
+ pkgver = 0.21.4
+ pkgrel = 1
+ url = https://github.com/MusicPlayerDaemon/MPD/pull/223
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = meson
+ makedepends = python-sphinx
+ depends = audiofile
+ depends = avahi
+ depends = curl
+ depends = faad2
+ depends = ffmpeg
+ depends = fluidsynth
+ depends = icu
+ depends = jack
+ depends = libao
+ depends = libcdio-paranoia
+ depends = libgme
+ depends = libid3tag
+ depends = libmad
+ depends = libmikmod
+ depends = libmms
+ depends = libmodplug
+ depends = libmpcdec
+ depends = libmpdclient
+ depends = libnfs
+ depends = libsamplerate
+ depends = libshout
+ depends = libsoxr
+ depends = libsystemd
+ depends = libupnp
+ depends = mpg123
+ depends = openal
+ depends = smbclient
+ depends = sqlite
+ depends = twolame
+ depends = wavpack
+ depends = wildmidi
+ depends = yajl
+ depends = zziplib
+ optdepends = youtube-dl: youtube and other streaming site support
+ conflicts = mpd
+ backup = etc/mpd.conf
+ source = https://www.musicpd.org/download/mpd/0.21/mpd-0.21.4.tar.xz
+ source = https://www.musicpd.org/download/mpd/0.21/mpd-0.21.4.tar.xz.sig
+ source = tmpfiles.d
+ source = sysusers.d
+ source = conf
+ source = youtube-dl.patch::https://github.com/MusicPlayerDaemon/MPD/compare/master...arcnmx:ytdl.patch
+ validpgpkeys = 0392335A78083894A4301C43236E8A58C6DB4512
+ sha256sums = 247112eabf1b818a4052db7f0f5917ab00831ebc60a1ec3bf1154da4dc16a5c7
+ sha256sums = SKIP
+ sha256sums = 2faa85c12449a5b3ca422ff1c1fa06d057c7e262a74bfa6298c914a92d6f2e7a
+ sha256sums = 0b74c6e5db08daab3091dc15a6b0c75210ba2f9e98fa074f6cfd605a461056b6
+ sha256sums = f40f68205834ca53cea3372e930bfe6c2f9ecc9df3b1605df2fec63a658b2e03
+ sha256sums = SKIP
+
+pkgname = mpd-youtube-dl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..40c2d5519a40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.xz
+/*.xz.sig
+/*.pkg.*
+/youtube-dl.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc1b99a38046
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Contributor: Ben <ben@benmazer.net>
+
+_pkgbase=mpd
+pkgname=${_pkgbase}-youtube-dl
+pkgver=0.21.4
+pkgrel=1
+pkgdesc='mpd fork with youtube support'
+url='https://github.com/MusicPlayerDaemon/MPD/pull/223'
+conflicts=('mpd')
+license=('GPL')
+arch=('x86_64')
+depends=('audiofile' 'avahi' 'curl' 'faad2' 'ffmpeg' 'fluidsynth' 'icu' 'jack'
+ 'libao' 'libcdio-paranoia' 'libgme' 'libid3tag' 'libmad' 'libmikmod'
+ 'libmms' 'libmodplug' 'libmpcdec' 'libmpdclient' 'libnfs'
+ 'libsamplerate' 'libshout' 'libsoxr' 'libsystemd' 'libupnp' 'mpg123'
+ 'openal' 'smbclient' 'sqlite' 'twolame' 'wavpack' 'wildmidi' 'yajl'
+ 'zziplib')
+optdepends=('youtube-dl: youtube and other streaming site support')
+makedepends=('boost' 'meson' 'python-sphinx')
+validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512')
+#source=("https://www.musicpd.org/download/${_pkgbase}/${pkgver}/${_pkgbase}-${pkgver}.tar.xz"{,.sig}
+source=("https://www.musicpd.org/download/${_pkgbase}/${pkgver%.*}/${_pkgbase}-${pkgver}.tar.xz"{,.sig}
+ 'tmpfiles.d'
+ 'sysusers.d'
+ 'conf'
+ 'youtube-dl.patch::https://github.com/MusicPlayerDaemon/MPD/compare/master...arcnmx:ytdl.patch')
+backup=('etc/mpd.conf')
+
+prepare() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ rm -fr build
+ install -d build
+ patch -Np1 < "${srcdir}/youtube-dl.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}/build"
+ _opts=('-Ddocumentation=true'
+ '-Dchromaprint=disabled' # appears not to be used for anything
+ '-Dsidplay=disabled' # unclear why but disabled in the past
+ '-Dlibwrap=disabled' # twentieth century's over
+ '-Dadplug=disabled' # not in an official repo
+ '-Dsndio=disabled' # interferes with detection of alsa devices
+ '-Dshine=disabled' # not in an official repo
+ )
+ arch-meson .. ${_opts[@]}
+ ninja
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}/build"
+ DESTDIR="${pkgdir}" ninja install
+ install -Dm644 ../doc/mpdconf.example "${pkgdir}"/usr/share/doc/mpd/mpdconf.example
+ install -Dm644 ../doc/mpd.conf.5 "${pkgdir}"/usr/share/man/man5/mpd.conf.5
+ install -Dm644 ../doc/mpd.1 "${pkgdir}"/usr/share/man/man1/mpd.1
+
+ install -Dm644 ../../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -Dm644 ../../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
+ install -Dm644 ../../conf "${pkgdir}"/etc/mpd.conf
+
+ sed \
+ -e '/\[Service\]/a User=mpd' \
+ -e '/WantedBy=/c WantedBy=default.target' \
+ -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+}
+
+# makepkg -g >> PKGBUILD
+sha256sums=('247112eabf1b818a4052db7f0f5917ab00831ebc60a1ec3bf1154da4dc16a5c7'
+ 'SKIP'
+ '2faa85c12449a5b3ca422ff1c1fa06d057c7e262a74bfa6298c914a92d6f2e7a'
+ '0b74c6e5db08daab3091dc15a6b0c75210ba2f9e98fa074f6cfd605a461056b6'
+ 'f40f68205834ca53cea3372e930bfe6c2f9ecc9df3b1605df2fec63a658b2e03'
+ 'SKIP')
diff --git a/conf b/conf
new file mode 100644
index 000000000000..da7d6fae92eb
--- /dev/null
+++ b/conf
@@ -0,0 +1,6 @@
+# See: /usr/share/doc/mpd/mpdconf.example
+
+pid_file "/run/mpd/mpd.pid"
+db_file "/var/lib/mpd/mpd.db"
+state_file "/var/lib/mpd/mpdstate"
+playlist_directory "/var/lib/mpd/playlists"
diff --git a/sysusers.d b/sysusers.d
new file mode 100644
index 000000000000..58d47478ea69
--- /dev/null
+++ b/sysusers.d
@@ -0,0 +1,2 @@
+u mpd 45 - /var/lib/mpd
+m mpd audio
diff --git a/tmpfiles.d b/tmpfiles.d
new file mode 100644
index 000000000000..bef72182b228
--- /dev/null
+++ b/tmpfiles.d
@@ -0,0 +1,3 @@
+d /run/mpd 0755 mpd mpd
+d /var/lib/mpd 0755 mpd mpd
+d /var/lib/mpd/playlists 0755 mpd mpd