summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZaZam2019-02-14 09:59:46 +0200
committerZaZam2019-02-14 09:59:46 +0200
commit8ab5441baed0cad4dfeb2dd0b70864eab92808ed (patch)
treeebff4e730eff0bc1117501dd383ce421085c4106
downloadaur-8ab5441baed0cad4dfeb2dd0b70864eab92808ed.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0048f33bcc9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mpd_queue_random_album-git
+ pkgdesc = Python program to append mpd queue with random albums.
+ pkgver = 1.0.0.843d9c3
+ pkgrel = 1
+ url = https://github.com/ibeex/mpd_queue_random_album
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-mpd2
+ conflicts = mpdrandom
+ source = git+https://github.com/ibeex/mpd_queue_random_album
+ md5sums = SKIP
+
+pkgname = mpd_queue_random_album-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d8c9bd2dd80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: ZaZam <zazaamm at gmail dot com>
+
+_gitname=mpd_queue_random_album
+pkgname=mpd_queue_random_album-git
+pkgver=1.0.0.843d9c3
+pkgrel=1
+pkgdesc="Python program to append mpd queue with random albums."
+arch=('any')
+url="https://github.com/ibeex/$_gitname"
+license=('MIT')
+depends=('python' 'python-mpd2')
+makedepends=('git')
+conflicts=('mpdrandom')
+source=("git+https://github.com/ibeex/$_gitname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+## getting the version from setup.py and the id of HEAD
+ printf "`grep -o 'version=".*"' setup.py | tr -d 'version="'`.`git rev-parse --short HEAD`"
+## git describe does not work here as there are no tags yet
+# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/"
+}