summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason S. Wagner2023-10-10 18:55:55 -0700
committerJason S. Wagner2023-10-10 18:55:55 -0700
commit3a2ce4712ec3ce2f23264ff375e7973c46cb54ad (patch)
tree173b55d5b062b26730e3485ea83e8e306b34fd33
parent75e691fdf3b5da5ade2d81bf8e159337971da267 (diff)
downloadaur-3a2ce4712ec3ce2f23264ff375e7973c46cb54ad.tar.gz
Bump to 2.7.0
-rw-r--r--.Changelog25
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 15 deletions
diff --git a/.Changelog b/.Changelog
new file mode 100644
index 000000000000..9fe2b26a95b1
--- /dev/null
+++ b/.Changelog
@@ -0,0 +1,25 @@
+# mpf-check-bin .Changelog
+
+## 2023-10-10, mpf-check-bin 2.7.0-1
+
+* Bump to 2.7.0 (2.6.7 was skipped).
+* Started maintenance of `.Changelog`.
+
+## 2023-10-08, mpf-check-bin 2.6.6-2
+
+* Migrated to Linux-native .NET Framework 7-based binary release. Previous
+PKGBUILDs consumed the .NET Framework 4.8 binary with a `mono` dependency and
+a convenience script to ease execution. .NET Framework 4.8 support is
+expected to be deprecated in MPF 2.6.7.
+
+
+## 2023-10-08, mpf-check-bin 2.6.6-1
+
+* Bump to v2.6.6 release.
+
+# FAQ
+
+## Why consume the release binary rather than compile from source?
+
+I can't be bothered at the moment.
+
diff --git a/.SRCINFO b/.SRCINFO
index 5936cf14a278..eaf605e9f97f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = mpf-check-bin
pkgdesc = Media Preservation Frontend for Aaru and Redumper in C# (CLI Version)
- pkgver = 2.6.6
- pkgrel = 2
+ pkgver = 2.7.0
+ pkgrel = 1
url = https://github.com/SabreTools/MPF
arch = x86_64
license = GPL3
provides = mpf-check
options = !strip
- source = https://github.com/SabreTools/MPF/releases/download/2.6.6/MPF.Check_2.6.6-net7.0_linux-x64.zip
+ source = https://github.com/SabreTools/MPF/releases/download/2.7.0/MPF.Check_2.7.0_net7.0_linux-x64_release.zip
source = https://raw.githubusercontent.com/SabreTools/MPF/master/README.md
source = https://raw.githubusercontent.com/SabreTools/MPF/master/LICENSE
- sha256sums = 1cedcc285d3e9d85b2f6abb675f80359ae0eb9062a37602de3b8f2afb30dcc5b
+ sha256sums = 8310ebd77866ad7c4060e6ca27cddc6daced33e32561409aeb307757dd15a14b
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 26e5462a058f..58439db6198b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@ url="https://github.com/SabreTools/MPF"
arch=('x86_64')
pkgdesc="Media Preservation Frontend for Aaru and Redumper in C# (CLI Version)"
provides=('mpf-check')
-pkgver=2.6.6
-pkgrel=2
+pkgver=2.7.0
+pkgrel=1
license=('GPL3')
-source=('https://github.com/SabreTools/MPF/releases/download/2.6.6/MPF.Check_2.6.6-net7.0_linux-x64.zip'
+source=('https://github.com/SabreTools/MPF/releases/download/2.7.0/MPF.Check_2.7.0_net7.0_linux-x64_release.zip'
'https://raw.githubusercontent.com/SabreTools/MPF/master/README.md'
'https://raw.githubusercontent.com/SabreTools/MPF/master/LICENSE')
-sha256sums=('1cedcc285d3e9d85b2f6abb675f80359ae0eb9062a37602de3b8f2afb30dcc5b'
+sha256sums=('8310ebd77866ad7c4060e6ca27cddc6daced33e32561409aeb307757dd15a14b'
'SKIP'
'SKIP')
options=('!strip')
@@ -21,16 +21,15 @@ package() {
# install mpf-check distribution
install -Dm 755 ${srcdir}/MPF.Check ${pkgdir}/usr/bin/MPF.Check
- install -Dm 644 ${srcdir}/MPF.Check.dll.config ${pkgdir}/usr/lib/${_prgname}/MPF.Check.dll.config
- install -Dm 644 ${srcdir}/MPF.Check.pdb ${pkgdir}/usr/lib/${_prgname}/MPF.Check.pdb
- install -Dm 644 ${srcdir}/MPF.Core.pdb ${pkgdir}/usr/lib/${_prgname}/MPF.Core.pdb
- install -Dm 644 ${srcdir}/MPF.Library.pdb ${pkgdir}/usr/lib/${_prgname}/MPF.Library.pdb
- install -Dm 644 ${srcdir}/MPF.Modules.pdb ${pkgdir}/usr/lib/${_prgname}/MPF.Modules.pdb
+ install -Dm 644 ${srcdir}/MPF.Check.dll.config \
+ ${pkgdir}/usr/lib/${_prgname}/MPF.Check.dll.config
# install documentation
- install -Dm 644 ${srcdir}/README.md ${pkgdir}/usr/local/share/doc/${_prgname}/README.md
+ install -Dm 644 ${srcdir}/README.md \
+ ${pkgdir}/usr/local/share/doc/${_prgname}/README.md
# install license
- install -Dm 644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${_prgname}/LICENSE
+ install -Dm 644 ${srcdir}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${_prgname}/LICENSE
}