summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason S. Wagner2023-10-26 20:23:55 -0700
committerJason S. Wagner2023-10-26 20:23:55 -0700
commit91a1a789e5caedb448d1c39cad0016a4c6a675eb (patch)
tree76c860eec0cb4a5ba8e709a4bd8c977fdd02ed83
parent2145969742e399f34a4a8f66fb8801af6fef923d (diff)
downloadaur-91a1a789e5caedb448d1c39cad0016a4c6a675eb.tar.gz
Stop leaning on release distribution dependencies, use AUR packages.
-rw-r--r--.Changelog5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD15
3 files changed, 13 insertions, 24 deletions
diff --git a/.Changelog b/.Changelog
index 641bdeec3674..1c53f83fa7f3 100644
--- a/.Changelog
+++ b/.Changelog
@@ -1,5 +1,10 @@
# mpf-check-bin .Changelog
+## 2023-10-26, mpf-check-bin 2.7.3-2
+
+* Added dependency on `casclib` and `stormlib`
+* Release distribution `CascLib.dll` and `StormLib.dll` are now discarded.
+
## 2023-10-26, mpf-check-bin 2.7.3-1
* Bump to 2.7.3
diff --git a/.SRCINFO b/.SRCINFO
deleted file mode 100644
index ff1fe98fb30d..000000000000
--- a/.SRCINFO
+++ /dev/null
@@ -1,17 +0,0 @@
-pkgbase = mpf-check-bin
- pkgdesc = Media Preservation Frontend for Aaru and Redumper in C# (CLI Version)
- pkgver = 2.7.3
- pkgrel = 1
- url = https://github.com/SabreTools/MPF
- arch = x86_64
- license = GPL3
- provides = mpf-check
- options = !strip
- source = https://github.com/SabreTools/MPF/releases/download/2.7.3/MPF.Check_2.7.3_net7.0_linux-x64_release.zip
- source = https://raw.githubusercontent.com/SabreTools/MPF/master/README.md
- source = https://raw.githubusercontent.com/SabreTools/MPF/master/LICENSE
- sha256sums = 7f7ee3ef1ba9862459fb57fab7d499b6583c0a752a8fd1b4ff79edcd284a45a7
- sha256sums = SKIP
- sha256sums = SKIP
-
-pkgname = mpf-check-bin
diff --git a/PKGBUILD b/PKGBUILD
index 31f6c63c0952..236a54a0f421 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,30 @@ _prgname=MPF.Check
pkgname=mpf-check-bin
url="https://github.com/SabreTools/MPF"
arch=('x86_64')
+depends=('casclib' 'stormlib')
+license=('GPL3')
+options=('!strip')
pkgdesc="Media Preservation Frontend for Aaru and Redumper in C# (CLI Version)"
provides=('mpf-check')
pkgver=2.7.3
-pkgrel=1
-license=('GPL3')
+pkgrel=2
source=('https://github.com/SabreTools/MPF/releases/download/2.7.3/MPF.Check_2.7.3_net7.0_linux-x64_release.zip'
'https://raw.githubusercontent.com/SabreTools/MPF/master/README.md'
'https://raw.githubusercontent.com/SabreTools/MPF/master/LICENSE')
sha256sums=('7f7ee3ef1ba9862459fb57fab7d499b6583c0a752a8fd1b4ff79edcd284a45a7'
'SKIP'
'SKIP')
-options=('!strip')
package() {
# install mpf-check distribution
install -Dm 755 ${srcdir}/${_prgname} ${pkgdir}/usr/bin/${_prgname}
- install -Dm 644 ${srcdir}/CascLib.dll \
- ${pkgdir}/usr/lib/${_prgname}/CascLib.dll
+ #install -Dm 644 ${srcdir}/CascLib.dll \
+ # ${pkgdir}/usr/lib/${_prgname}/CascLib.dll
install -Dm 644 ${srcdir}/MPF.Check.dll.config \
${pkgdir}/usr/lib/${_prgname}/MPF.Check.dll.config
- install -Dm 644 ${srcdir}/StormLib.dll \
- ${pkgdir}/usr/lib/${_prgname}/StormLib.dll
+ #install -Dm 644 ${srcdir}/StormLib.dll \
+ # ${pkgdir}/usr/lib/${_prgname}/StormLib.dll
# install documentation
install -Dm 644 ${srcdir}/README.md \