summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-09 11:26:52 -0400
committerKyle Keen2015-08-09 11:26:52 -0400
commit2684cfd38a73a8dc40eaa99e037ab5e3eb94a7e5 (patch)
tree03e4c15d86900587773535acc5f6066de9bdf9de
downloadaur-mpfc.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--mpfc.install20
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e8491417041
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mpfc
+ pkgdesc = A gstreamer-based audio player with curses interface.
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/mpfc/
+ install = mpfc.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gst-plugins-base-libs
+ depends = json-glib
+ depends = taglib
+ depends = gpm
+ source = http://downloads.sourceforge.net/project/mpfc/mpfc/mpfc-2.0.tar.gz
+ md5sums = c53702073827b3ec984a51ea6c03c7b0
+
+pkgname = mpfc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9245e81634b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: speps <speps at aur dot archlinux dot org>
+
+pkgname=mpfc
+pkgver=2.0
+pkgrel=1
+pkgdesc="A gstreamer-based audio player with curses interface."
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects/mpfc/"
+license=('GPL')
+depends=('gst-plugins-base-libs' 'json-glib' 'taglib' 'gpm')
+install="$pkgname.install"
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('c53702073827b3ec984a51ea6c03c7b0')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-static=no
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/mpfc.install b/mpfc.install
new file mode 100644
index 000000000000..2d4ad4d67102
--- /dev/null
+++ b/mpfc.install
@@ -0,0 +1,20 @@
+infodir=usr/share/info
+filelist=(mpfc.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}