summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-10 16:55:47 +0800
committerChocobo12023-04-10 16:55:47 +0800
commitac2eb7569c50eabaa335054f8cfeb4e489cdbe16 (patch)
tree5a9cbb95a0771efe1b8026b62e60d04843d87117
parent472b550dbbd1b6e8dcae3e30b24185a184ab24ec (diff)
downloadaur-mpfr-git.tar.gz
upgpkg: mpfr-git 4.2.0.r140.g4e0324cb2-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aec952dc5dc2..f4d5018395a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpfr-git
pkgdesc = C library for multiple-precision floating-point computations with correct rounding
- pkgver = r13607.gec77070d4
+ pkgver = 4.2.0.r140.g4e0324cb2
pkgrel = 1
url = https://www.mpfr.org/
arch = i686
@@ -10,7 +10,7 @@ pkgbase = mpfr-git
makedepends = git
depends = glibc
depends = gmp
- provides = mpfr
+ provides = mpfr=4.2.0.r140.g4e0324cb2
conflicts = mpfr
options = staticlibs
source = git+https://gitlab.inria.fr/mpfr/mpfr.git
diff --git a/PKGBUILD b/PKGBUILD
index 39b3c236bc81..90606173d719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=mpfr-git
-pkgver=r13607.gec77070d4
+pkgver=4.2.0.r140.g4e0324cb2
pkgrel=1
pkgdesc="C library for multiple-precision floating-point computations with correct rounding"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.mpfr.org/"
license=('GPL3' 'LGPL3')
depends=('glibc' 'gmp')
makedepends=('git')
-provides=('mpfr')
+provides=("mpfr=$pkgver")
conflicts=('mpfr')
options=('staticlibs')
source=("git+https://gitlab.inria.fr/mpfr/mpfr.git")
@@ -19,9 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "mpfr"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {