summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-05-04 22:42:45 +0800
committerChocobo12022-05-04 22:50:57 +0800
commit472b550dbbd1b6e8dcae3e30b24185a184ab24ec (patch)
tree2c446ace54bc9850e454baddaa3d71371791d84c
downloadaur-472b550dbbd1b6e8dcae3e30b24185a184ab24ec.tar.gz
newpkg: mpfr-git r13607.gec77070d4-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aec952dc5dc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mpfr-git
+ pkgdesc = C library for multiple-precision floating-point computations with correct rounding
+ pkgver = r13607.gec77070d4
+ pkgrel = 1
+ url = https://www.mpfr.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = git
+ depends = glibc
+ depends = gmp
+ provides = mpfr
+ conflicts = mpfr
+ options = staticlibs
+ source = git+https://gitlab.inria.fr/mpfr/mpfr.git
+ sha256sums = SKIP
+
+pkgname = mpfr-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39b3c236bc81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=mpfr-git
+pkgver=r13607.gec77070d4
+pkgrel=1
+pkgdesc="C library for multiple-precision floating-point computations with correct rounding"
+arch=('i686' 'x86_64')
+url="https://www.mpfr.org/"
+license=('GPL3' 'LGPL3')
+depends=('glibc' 'gmp')
+makedepends=('git')
+provides=('mpfr')
+conflicts=('mpfr')
+options=('staticlibs')
+source=("git+https://gitlab.inria.fr/mpfr/mpfr.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "mpfr"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "mpfr"
+
+ ./autogen.sh
+ ./configure \
+ --prefix="/usr" \
+ --enable-thread-safe
+ make
+}
+
+check() {
+ cd "mpfr"
+
+ make check
+}
+
+package() {
+ cd "mpfr"
+
+ make DESTDIR="$pkgdir" install
+}