summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2018-05-31 02:26:38 +0200
committerDaniel Maslowski2018-05-31 02:26:38 +0200
commit2a83a1532b3226aab29edc848c17dd3e88a94388 (patch)
tree5f3f520613a4379756dbb1cef060a150dcb063f1
downloadaur-2a83a1532b3226aab29edc848c17dd3e88a94388.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..466c80bfb7cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu May 31 00:26:32 UTC 2018
+pkgbase = mpfshell
+ pkgdesc = A simple shell based file explorer for ESP8266 Micropython based devices
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/wendlers/mpfshell
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pyserial
+ depends = python-colorama
+ depends = python-websocket-client
+ options = !emptydirs
+ source = https://github.com/wendlers/mpfshell/archive/0.8.1.tar.gz
+ sha512sums = a9107c031431eab53f514e6b16adb19551f0058d43b03e3fd1100faa3013f1fdcbcd5aca45e4dcc73ee5a318f40ae611eb0ad17eff9178fcfe65a093f581c6a5
+
+pkgname = mpfshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28c265fc516b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+pkgname=mpfshell
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="A simple shell based file explorer for ESP8266 Micropython based devices"
+arch=('any')
+url="https://github.com/wendlers/mpfshell"
+license=('MIT')
+depends=('python' 'python-pyserial' 'python-colorama' 'python-websocket-client')
+options=(!emptydirs)
+source=("https://github.com/wendlers/mpfshell/archive/${pkgver}.tar.gz")
+sha512sums=('a9107c031431eab53f514e6b16adb19551f0058d43b03e3fd1100faa3013f1fdcbcd5aca45e4dcc73ee5a318f40ae611eb0ad17eff9178fcfe65a093f581c6a5')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: