summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2015-06-23 10:28:34 +0200
committerPeter Ivanov2015-06-23 10:28:34 +0200
commita58ebffef595e9cd50129d591269357a313bdf50 (patch)
tree31b95f0b8320ccfdfb125bcaa2e4a6d927fa9c4f
downloadaur-a58ebffef595e9cd50129d591269357a313bdf50.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
3 files changed, 70 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7d7c5a3e7fa5
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = mphidflash
+ pkgdesc = Flash utility for Microchip PIC microcontrollers with USB HID-Bootloader
+ pkgver = r24
+ pkgrel = 1
+ url = https://code.google.com/p/mphidflash
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = svn
+ makedepends = gcc
+ source = svn+http://mphidflash.googlecode.com/svn/trunk/
+
+pkgname = mphidflash
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c28d4017a271
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mphidflash
+ pkgdesc = Flash utility for Microchip PIC microcontrollers with USB HID-Bootloader
+ pkgver = r24
+ pkgrel = 1
+ url = https://code.google.com/p/mphidflash
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = svn
+ makedepends = gcc
+ source = svn+http://mphidflash.googlecode.com/svn/trunk/
+ md5sums = SKIP
+
+pkgname = mphidflash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe6509e99fe5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Peter Ivanov <ivanovp@gmail.com>
+
+pkgname=mphidflash
+pkgver=r24
+pkgrel=1
+pkgdesc="Flash utility for Microchip PIC microcontrollers with USB HID-Bootloader"
+arch=("i686" "x86_64")
+url="https://code.google.com/p/mphidflash"
+license=("GPL3")
+depends=()
+makedepends=(svn gcc)
+#options=('!strip')
+source=("svn+http://mphidflash.googlecode.com/svn/trunk/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/trunk"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$srcdir/trunk"
+ if [ $CARCH = i686 ]; then
+ make mphidflash32
+ else
+ make mphidflash64
+ fi
+}
+
+package() {
+ cd "$srcdir/trunk/binaries"
+ if [ $CARCH = i686 ]; then
+ install -D mphidflash-1.6-linux-32 $pkgdir/usr/bin/mphidflash
+ else
+ install -D mphidflash-1.6-linux-64 $pkgdir/usr/bin/mphidflash
+ fi
+}
+
+# vim:sw=2:
+