summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2017-03-05 16:29:19 +0100
committerPeter Ivanov2017-03-05 16:29:19 +0100
commitc79f85765de5f306f6ea36286309673264d2cdd9 (patch)
tree004017b85d4d643633653002dffbb913389d1467
parent6d4c4599937c5dc7d492d1226b58d690b98fdfc3 (diff)
downloadaur-c79f85765de5f306f6ea36286309673264d2cdd9.tar.gz
Changes to github source.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c28d4017a271..962f24abfbaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Mar 5 15:29:19 UTC 2017
pkgbase = mphidflash
pkgdesc = Flash utility for Microchip PIC microcontrollers with USB HID-Bootloader
- pkgver = r24
+ pkgver = 20150703
pkgrel = 1
url = https://code.google.com/p/mphidflash
arch = i686
@@ -8,7 +10,7 @@ pkgbase = mphidflash
license = GPL3
makedepends = svn
makedepends = gcc
- source = svn+http://mphidflash.googlecode.com/svn/trunk/
+ source = mphidflash::git+https://github.com/ApertureLabsLtd/mphidflash
md5sums = SKIP
pkgname = mphidflash
diff --git a/PKGBUILD b/PKGBUILD
index fe6509e99fe5..d8217062d7ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Peter Ivanov <ivanovp@gmail.com>
pkgname=mphidflash
-pkgver=r24
+pkgver=20150703
pkgrel=1
pkgdesc="Flash utility for Microchip PIC microcontrollers with USB HID-Bootloader"
arch=("i686" "x86_64")
@@ -10,17 +10,16 @@ license=("GPL3")
depends=()
makedepends=(svn gcc)
#options=('!strip')
-source=("svn+http://mphidflash.googlecode.com/svn/trunk/")
+source=("$pkgname::git+https://github.com/ApertureLabsLtd/mphidflash")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/trunk"
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
+ cd "$srcdir/$_gitname"
+ git log -1 --format="%cd" --date=short | tr -d '-'
}
build() {
- cd "$srcdir/trunk"
+ cd "$srcdir/$pkgname"
if [ $CARCH = i686 ]; then
make mphidflash32
else
@@ -29,7 +28,7 @@ build() {
}
package() {
- cd "$srcdir/trunk/binaries"
+ cd "$srcdir/$pkgname/binaries"
if [ $CARCH = i686 ]; then
install -D mphidflash-1.6-linux-32 $pkgdir/usr/bin/mphidflash
else