summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2022-08-29 18:01:40 +0100
committerKuoi2022-08-29 18:01:40 +0100
commit829b5015fa8af1f8b34023bef434a26539a16804 (patch)
tree7d0be7a585960a2ff953c72383267d92d6a6b008
downloadaur-829b5015fa8af1f8b34023bef434a26539a16804.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66cc9245bc6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mpi-bucky
+ pkgdesc = Bayesian Untangling of Concordance Knots https://doi.org/10.1093/bioinformatics/btq539
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = https://github.com/tkchafin/mpi-bucky
+ arch = x86_64
+ license = GPL
+ makedepends = clang
+ makedepends = boost
+ makedepends = openmpi
+ depends = gcc-libs
+ depends = boost-libs
+ depends = openmpi
+ conflicts = bucky
+ source = git+https://github.com/tkchafin/mpi-bucky.git
+ sha256sums = SKIP
+
+pkgname = mpi-bucky
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8326d171dddb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=mpi-bucky
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="Bayesian Untangling of Concordance Knots https://doi.org/10.1093/bioinformatics/btq539"
+arch=('x86_64')
+conflicts=('bucky')
+url="https://github.com/tkchafin/mpi-bucky"
+license=('GPL')
+depends=('gcc-libs' 'boost-libs' 'openmpi')
+makedepends=('clang' 'boost' 'openmpi')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname/src"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/src"
+for bin in bucky mbsum
+do
+ install -Dm 755 $bin $pkgdir/usr/bin/$bin
+done
+}