summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Kotta2020-07-02 18:30:53 -0500
committerJonathan Kotta2020-07-02 18:30:53 -0500
commit85333ca27bfa748b9f20f102db31f288a27739d9 (patch)
tree6da39af5a16a7d5c61dfbe5f57b99b6bcbc52545
parent19ca142592dd91f0411c327b341f6b201aed77af (diff)
downloadaur-mpich2.tar.gz
build with gfortran-8
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
-rw-r--r--mpich2.profile5
3 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 619648766208..4e373d817612 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = mpich2
pkgdesc = An improved implementation of the Message Passing Interface (legacy version).
pkgver = 1.5
- pkgrel = 2
+ pkgrel = 3
url = http://mpich.org
install = mpich2.install
- arch = i686
arch = x86_64
license = custom
makedepends = libtool
@@ -12,10 +11,8 @@ pkgbase = mpich2
makedepends = coreutils
makedepends = texlive-core
makedepends = sowing
- depends = python2
- depends = gcc-fortran
+ depends = gcc8-fortran
depends = libxml2
- depends = openssh
depends = numactl
depends = pciutils
optdepends = java-environment
@@ -27,7 +24,7 @@ pkgbase = mpich2
source = mpich2.profile
md5sums = c60146aa6691005f2fb25973e144cfdc
md5sums = 661f5a993e1afb6c51fdd5ad529d628b
- md5sums = fb934502236ca58705f69db1749feb59
+ md5sums = 5cbf7c44567242e925ea3795262671e5
pkgname = mpich2
diff --git a/PKGBUILD b/PKGBUILD
index a6dcbec0b5a1..770a7dbbe2cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jonathan Kotta <jpkotta at gmail dot com>
pkgname=mpich2
pkgver=1.5
-pkgrel=2
+pkgrel=3
pkgdesc="An improved implementation of the Message Passing Interface (legacy version)."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://mpich.org"
license=('custom')
groups=()
-depends=(python2 gcc-fortran libxml2 openssh numactl pciutils)
+depends=(gcc8-fortran libxml2 numactl pciutils)
makedepends=(libtool make coreutils texlive-core sowing)
optdepends=(java-environment)
provides=()
@@ -24,7 +24,7 @@ source=(
)
md5sums=('c60146aa6691005f2fb25973e144cfdc'
'661f5a993e1afb6c51fdd5ad529d628b'
- 'fb934502236ca58705f69db1749feb59')
+ '5cbf7c44567242e925ea3795262671e5')
noextract=()
build() {
@@ -38,15 +38,23 @@ build() {
export MPICH2LIB_CFLAGS="$CFLAGS"; unset CFLAGS
export MPICH2LIB_CXXFLAGS="$CXXFLAGS"; unset CXXFLAGS
export MPICH2LIB_FFLAGS="$FFLAGS"; unset FFLAGS
- export MPICH2LIB_F90FLAGS="$F90FLAGS"; unset F90FLAGS
+ export MPICH2LIB_FCFLAGS="$FCFLAGS"; unset FCFLAGS
export MPICH2LIB_LDFLAGS="$LDFLAGS"; unset LDFLAGS
- ./configure --prefix=/opt/$pkgname --enable-shared --enable-sharedlibs=gcc \
+ ./configure \
+ --prefix=/opt/$pkgname \
+ --enable-shared --enable-sharedlibs=gcc \
--enable-error-checking=runtime --enable-error-messages=all \
+ --enable-fc --enable-f77 --enable-cxx \
+ --enable-g=meminit \
+ --with-pm=hydra:gforker:mpd \
--enable-timer-type=clock_gettime \
- --with-pm=hydra:gforker:mpd --with-python=python2 \
- --disable-rpath \
- --enable-fc --enable-f77 --enable-cxx
+ --disable-wrapper-rpath \
+ --with-device=ch3:nemesis \
+ CC=gcc-8 CXX=g++-8 F77=gfortran-8 FC=gfortran-8 \
+ FFLAGS=-Wno-argument-mismatch \
+ FCFLAGS=-Wno-argument-mismatch
+
make
}
diff --git a/mpich2.profile b/mpich2.profile
index 1cf217e109b7..020d0481ebb9 100644
--- a/mpich2.profile
+++ b/mpich2.profile
@@ -1,2 +1,3 @@
-export PATH=$PATH:/opt/mpich2/bin
-export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/mpich2/lib/pkgconfig
+export PATH=${PATH}:/opt/mpich2/bin
+export MANPATH=${MANPATH}:/opt/mpich2/share/man
+export PKG_CONFIG_PATH=${PKG_CONFIG_PATH}:/opt/mpich2/lib/pkgconfig