summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:11:12 +0100
committerSteven Honeyman2015-06-09 19:11:12 +0100
commite07d5111e88f1277a390d546d10c716caa0be88c (patch)
tree233dc17e9ca6eabedeb747de74597d423dc7d48e
downloadaur-mplayer-light-svn.tar.gz
Initial import
-rw-r--r--.SRCINFO63
-rw-r--r--PKGBUILD99
-rw-r--r--cdio-includes.patch43
-rw-r--r--mplayer.desktop22
4 files changed, 227 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..559bf60756f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,63 @@
+pkgbase = mplayer-light-svn
+ pkgdesc = Media player for Linux (no lirc-utils and smbclient deps)
+ pkgver = 37352
+ pkgrel = 1
+ url = http://www.mplayerhq.hu/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = sdl
+ makedepends = libdca
+ makedepends = mesa
+ makedepends = yasm
+ makedepends = svn
+ depends = desktop-file-utils
+ depends = ttf-font
+ depends = enca
+ depends = libxss
+ depends = a52dec
+ depends = libvpx
+ depends = x264
+ depends = libmng
+ depends = libdca
+ depends = lame
+ depends = fontconfig
+ depends = libgl
+ depends = libxinerama
+ depends = libvdpau
+ depends = xvidcore
+ depends = opencore-amr
+ depends = libmad
+ depends = sdl
+ depends = libtheora
+ depends = libxxf86dga
+ depends = fribidi
+ depends = libjpeg
+ depends = faac
+ depends = faad2
+ depends = libxvmc
+ depends = schroedinger
+ depends = mpg123
+ depends = libass
+ depends = libxxf86vm
+ depends = libbluray
+ depends = libcdio-paranoia
+ depends = opus
+ provides = mplayer
+ conflicts = mplayer
+ options = !buildflags
+ options = !emptydirs
+ options = strip
+ backup = etc/mplayer/codecs.conf
+ backup = etc/mplayer/input.conf
+ source = svn://svn.mplayerhq.hu/mplayer/trunk
+ source = http://www.ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
+ source = mplayer.desktop
+ source = cdio-includes.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 62f44a58f072b2b1a3c3d3e4976d64b3
+ md5sums = 7b5be7191aafbea64218dc4916343bbc
+
+pkgname = mplayer-light-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d20602a2a266
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,99 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+#
+# Modified from Arch to remove lirc-utils and smbclient requirements
+# Also use latest svn build, with ffmpeg latest snapshot
+#
+
+pkgname='mplayer-light-svn'
+pkgver=37352
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc='Media player for Linux (no lirc-utils and smbclient deps)'
+makedepends=('sdl' 'libdca' 'mesa' 'yasm' 'svn')
+depends=(
+ 'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
+ 'x264' 'libmng' 'libdca' 'lame' 'fontconfig'
+ 'libgl' 'libxinerama' 'libvdpau' 'xvidcore'
+ 'opencore-amr' 'libmad' 'sdl' 'libtheora' 'libxxf86dga'
+ 'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
+ 'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus'
+)
+provides=('mplayer')
+conflicts=('mplayer')
+backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
+license=('GPL')
+url='http://www.mplayerhq.hu/'
+options=('!buildflags' '!emptydirs' 'strip')
+source=(svn://svn.mplayerhq.hu/mplayer/trunk
+ http://www.ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
+ mplayer.desktop
+ cdio-includes.patch)
+md5sums=('SKIP'
+ 'SKIP'
+ '62f44a58f072b2b1a3c3d3e4976d64b3'
+ '7b5be7191aafbea64218dc4916343bbc'
+ )
+
+pkgver() {
+ cd trunk
+ svnversion
+}
+
+prepare() {
+ cd trunk
+ mv ../ffmpeg .
+
+ patch -p0 -i ../cdio-includes.patch
+
+ echo "#define VERSION \"SVN-r$pkgver\"" > version.h
+ echo '#define MP_TITLE "%s "VERSION" (C) 2000-2014 MPlayer Team\n"' >> version.h
+}
+
+build() {
+ cd trunk
+
+ ./configure --prefix=/usr \
+ --enable-runtime-cpudetection \
+ --disable-gui \
+ --disable-arts \
+ --disable-liblzo \
+ --disable-speex \
+ --disable-openal \
+ --disable-libdv \
+ --disable-musepack \
+ --disable-esd \
+ --disable-mga \
+ --disable-ass-internal \
+ --disable-cdparanoia \
+ --disable-xvmc \
+ --disable-radio \
+ --disable-radio-capture \
+ --disable-tv \
+ --disable-smb \
+ --disable-lirc \
+ --disable-jack \
+ --disable-pulse \
+ --disable-caca \
+ --disable-inet6 \
+ --disable-ladspa \
+ --disable-aa \
+ --language=en \
+ --confdir=/etc/mplayer
+ [[ "$CARCH" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
+
+ make
+}
+
+package() {
+ cd trunk
+ make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
+
+ install -Dm644 etc/{codecs.conf,input.conf,example.conf} \
+ "$pkgdir/etc/mplayer/"
+
+ install -Dm644 ../mplayer.desktop \
+ "$pkgdir"/usr/share/applications/mplayer.desktop
+
+ install -Dm644 etc/mplayer256x256.png \
+ "$pkgdir"/usr/share/pixmaps/mplayer.png
+}
diff --git a/cdio-includes.patch b/cdio-includes.patch
new file mode 100644
index 000000000000..f71472812b72
--- /dev/null
+++ b/cdio-includes.patch
@@ -0,0 +1,43 @@
+Index: configure
+===================================================================
+--- configure (revision 35421)
++++ configure (working copy)
+@@ -5968,8 +5968,8 @@
+ cat > $TMPC << EOF
+ #include <stdio.h>
+ #include <cdio/version.h>
+-#include <cdio/cdda.h>
+-#include <cdio/paranoia.h>
++#include <cdio/paranoia/cdda.h>
++#include <cdio/paranoia/paranoia.h>
+ int main(void) {
+ void *test = cdda_verbose_set;
+ printf("%s\n", CDIO_VERSION);
+Index: gui/win32/interface.c
+===================================================================
+--- gui/win32/interface.c (revision 35421)
++++ gui/win32/interface.c (working copy)
+@@ -24,7 +24,7 @@
+ #include "config.h"
+
+ #if defined(CONFIG_LIBCDIO)
+-#include <cdio/cdda.h>
++#include <cdio/paranoia/cdda.h>
+ #elif defined(CONFIG_CDDA)
+ #include <cdda_interface.h>
+ #endif
+Index: stream/stream_cdda.c
+===================================================================
+--- stream/stream_cdda.c (revision 35421)
++++ stream/stream_cdda.c (working copy)
+@@ -21,8 +21,8 @@
+ #include <cdda_interface.h>
+ #include <cdda_paranoia.h>
+ #else
+-#include <cdio/cdda.h>
+-#include <cdio/paranoia.h>
++#include <cdio/paranoia/cdda.h>
++#include <cdio/paranoia/paranoia.h>
+ #endif
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/mplayer.desktop b/mplayer.desktop
new file mode 100644
index 000000000000..946b8e345c22
--- /dev/null
+++ b/mplayer.desktop
@@ -0,0 +1,22 @@
+[Desktop Entry]
+Type=Application
+Name=MPlayer Media Player
+Name[ca]=Reproductor multimèdia MPlayer
+Name[pl]=MPlayer odtwarzacz multimedialny
+GenericName=Multimedia player
+Comment=Play movies and songs
+Comment[ca]=Reproduïu vídeos i cançons
+Comment[de]=Filme und Musik abspielen
+Comment[es]=Reproduzca vídeos y canciones
+Comment[fr]=Lecteur multimédia
+Comment[it]=Lettore multimediale
+Comment[zh]=多媒体播放器
+Comment[pl]=Odtwarzaj filmy i muzykę
+Icon=mplayer
+TryExec=mplayer
+Exec=mplayer %F
+Terminal=false
+NoDisplay=true
+Categories=GTK;AudioVideo;Audio;Video;Player;TV;
+MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;
+X-KDE-Protocols=http,ftp,smb