summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranergy2015-09-02 08:29:46 +0900
committeranergy2015-09-02 08:33:45 +0900
commit7dde3c5b8d6e4a7bcba5ed6a9f6fe82dc8c13dc0 (patch)
treec70f4826bd3b323175202b83f638b2f22cc9de46
parent9c2cb6a7882d58813b718cec8e84cf8bbf2afdf5 (diff)
downloadaur-7dde3c5b8d6e4a7bcba5ed6a9f6fe82dc8c13dc0.tar.gz
Added /etc/X11/xorg.conf.d/10-mplus-font.conf
which makes the fontpath "/usr/share/fonts/mplus" persistent.
-rw-r--r--10-mplus-font.conf3
-rw-r--r--PKGBUILD11
-rw-r--r--mplus-font.install2
3 files changed, 12 insertions, 4 deletions
diff --git a/10-mplus-font.conf b/10-mplus-font.conf
new file mode 100644
index 000000000000..60c48e46f9c8
--- /dev/null
+++ b/10-mplus-font.conf
@@ -0,0 +1,3 @@
+Section "Files"
+ FontPath "/usr/share/fonts/mplus/"
+EndSection
diff --git a/PKGBUILD b/PKGBUILD
index 1e9338e56939..7d4761dd399a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mplus-font
pkgver=2.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="M+ Japanese bitmap fonts"
arch=(any)
license=('custom')
@@ -12,8 +12,10 @@ depends=('xorg-xset')
makedepends=('xorg-bdftopcf')
install="$pkgname.install"
url="http://mplus-fonts.sourceforge.jp/"
-source=("http://osdn.dl.sourceforge.jp/mplus-fonts/5030/mplus_bitmap_fonts-${pkgver}.tar.gz")
-md5sums=('a97a99acbee54976407dec828d03850c')
+source=("http://osdn.dl.sourceforge.jp/mplus-fonts/5030/mplus_bitmap_fonts-${pkgver}.tar.gz"
+ "10-mplus-font.conf")
+md5sums=('a97a99acbee54976407dec828d03850c'
+ 'f3f797ccbfc193f46fde7c4bd1c6edac')
build() {
return 0
@@ -24,5 +26,6 @@ package() {
DESTDIR=$pkgdir/usr/share/fonts/mplus ./install_mplus_fonts || return 1
mkdir -p $pkgdir/usr/share/licenses/custom/${pkgname}
- install -m644 LICENSE_E $pkgdir/usr/share/licenses/custom/${pkgname}/license.txt
+ install -m644 LICENSE_E ${pkgdir}/usr/share/licenses/custom/${pkgname}/license.txt
+ install -m644 10-mplus-font.conf ${pkgdir}/etc/X11/xorg.conf.d/10-mplus-font.conf
}
diff --git a/mplus-font.install b/mplus-font.install
index b48997e06a5d..1347bf314c2e 100644
--- a/mplus-font.install
+++ b/mplus-font.install
@@ -1,5 +1,6 @@
post_install() {
echo -n "Updating font cache... "
+ fc-cache -s
xset fp+ /usr/share/fonts/mplus
xset fp rehash
echo "done."
@@ -10,6 +11,7 @@ post_upgrade() {
}
post_remove() {
+ fc-cache -s
xset fp- /usr/share/fonts/mplus
xset fp rehash
}