summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranergy2015-08-28 10:26:38 +0900
committeranergy2015-08-28 10:42:43 +0900
commit9c2cb6a7882d58813b718cec8e84cf8bbf2afdf5 (patch)
treef38362208af7b370f51b0346b358b34b309a1a45
downloadaur-9c2cb6a7882d58813b718cec8e84cf8bbf2afdf5.tar.gz
Initial import.
Original PKGBUILD is mplus-bitmap-fonts, which is maintained by smly. 1. "pkgname" is renamed to be consistent with other bitmap font packages. 2. "arch" is now 'any', not architecture specific. 2. "depends" has changed from 'xorg-font-utils' to 'xorg-xset' 3. "makedepend" has now 'xorg-bdftopcf'
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--mplus-font.install15
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6aaccc5590d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mplus-font
+ pkgdesc = M+ Japanese bitmap fonts
+ pkgver = 2.2.4
+ pkgrel = 2
+ url = http://mplus-fonts.sourceforge.jp/
+ install = mplus-font.install
+ arch = any
+ license = custom
+ depends = xorg-xset
+ source = http://osdn.dl.sourceforge.jp/mplus-fonts/5030/mplus_bitmap_fonts-2.2.4.tar.gz
+ md5sums = a97a99acbee54976407dec828d03850c
+
+pkgname = mplus-font
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e9338e56939
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : anergy <anergy dot 25110321 at gmail dot com>
+# Contributor(previous maintainer) : smly <eowner at gmail dot com>
+# Contributor : muflax <muflax at gmail dot com>
+
+pkgname=mplus-font
+pkgver=2.2.4
+pkgrel=2
+pkgdesc="M+ Japanese bitmap fonts"
+arch=(any)
+license=('custom')
+depends=('xorg-xset')
+makedepends=('xorg-bdftopcf')
+install="$pkgname.install"
+url="http://mplus-fonts.sourceforge.jp/"
+source=("http://osdn.dl.sourceforge.jp/mplus-fonts/5030/mplus_bitmap_fonts-${pkgver}.tar.gz")
+md5sums=('a97a99acbee54976407dec828d03850c')
+
+build() {
+ return 0
+}
+
+package() {
+ cd $srcdir/mplus_bitmap_fonts-$pkgver
+
+ DESTDIR=$pkgdir/usr/share/fonts/mplus ./install_mplus_fonts || return 1
+ mkdir -p $pkgdir/usr/share/licenses/custom/${pkgname}
+ install -m644 LICENSE_E $pkgdir/usr/share/licenses/custom/${pkgname}/license.txt
+}
diff --git a/mplus-font.install b/mplus-font.install
new file mode 100644
index 000000000000..b48997e06a5d
--- /dev/null
+++ b/mplus-font.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ xset fp+ /usr/share/fonts/mplus
+ xset fp rehash
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ xset fp- /usr/share/fonts/mplus
+ xset fp rehash
+}