summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranergy2015-09-02 08:29:46 +0900
committeranergy2015-09-03 15:01:12 +0900
commitb4458f9ea3f219ce32bdcc062b305c1af2aceb5d (patch)
tree6c84ac4cd24df63340d282e227edb93399b62f94
parent9c2cb6a7882d58813b718cec8e84cf8bbf2afdf5 (diff)
downloadaur-b4458f9ea3f219ce32bdcc062b305c1af2aceb5d.tar.gz
Added /etc/X11/xorg.conf.d/10-mplus-font.conf
which makes the fontpath "/usr/share/fonts/mplus" persistent.
-rw-r--r--10-mplus-font.conf3
-rw-r--r--PKGBUILD23
-rw-r--r--mplus-font.install2
3 files changed, 19 insertions, 9 deletions
diff --git a/10-mplus-font.conf b/10-mplus-font.conf
new file mode 100644
index 000000000000..60c48e46f9c8
--- /dev/null
+++ b/10-mplus-font.conf
@@ -0,0 +1,3 @@
+Section "Files"
+ FontPath "/usr/share/fonts/mplus/"
+EndSection
diff --git a/PKGBUILD b/PKGBUILD
index 1e9338e56939..4e15cfd3fa71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mplus-font
pkgver=2.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="M+ Japanese bitmap fonts"
arch=(any)
license=('custom')
@@ -12,17 +12,22 @@ depends=('xorg-xset')
makedepends=('xorg-bdftopcf')
install="$pkgname.install"
url="http://mplus-fonts.sourceforge.jp/"
-source=("http://osdn.dl.sourceforge.jp/mplus-fonts/5030/mplus_bitmap_fonts-${pkgver}.tar.gz")
-md5sums=('a97a99acbee54976407dec828d03850c')
+source=("http://osdn.dl.sourceforge.jp/mplus-fonts/5030/mplus_bitmap_fonts-${pkgver}.tar.gz"
+ "10-mplus-font.conf")
+md5sums=('a97a99acbee54976407dec828d03850c'
+ 'f3f797ccbfc193f46fde7c4bd1c6edac')
build() {
- return 0
+ mkdir -p ${srcdir}/mplus_build
+ cd $srcdir/mplus_bitmap_fonts-$pkgver
+ DESTDIR=${srcdir}/mplus_build ./install_mplus_fonts || return 1
}
package() {
- cd $srcdir/mplus_bitmap_fonts-$pkgver
-
- DESTDIR=$pkgdir/usr/share/fonts/mplus ./install_mplus_fonts || return 1
- mkdir -p $pkgdir/usr/share/licenses/custom/${pkgname}
- install -m644 LICENSE_E $pkgdir/usr/share/licenses/custom/${pkgname}/license.txt
+ mkdir -p ${pkgdir}/usr/share/fonts/mplus
+ cp mplus_build/* ${pkgdir}/usr/share/fonts/mplus/
+ cd $srcdir/mplus_bitmap_fonts-$pkgver
+ mkdir -p $pkgdir/usr/share/licenses/custom/${pkgname}
+ install -m644 LICENSE_E ${pkgdir}/usr/share/licenses/custom/${pkgname}/license.txt
+ install -m644 -D ${srcdir}/10-mplus-font.conf ${pkgdir}/etc/X11/xorg.conf.d/10-mplus-font.conf
}
diff --git a/mplus-font.install b/mplus-font.install
index b48997e06a5d..1347bf314c2e 100644
--- a/mplus-font.install
+++ b/mplus-font.install
@@ -1,5 +1,6 @@
post_install() {
echo -n "Updating font cache... "
+ fc-cache -s
xset fp+ /usr/share/fonts/mplus
xset fp rehash
echo "done."
@@ -10,6 +11,7 @@ post_upgrade() {
}
post_remove() {
+ fc-cache -s
xset fp- /usr/share/fonts/mplus
xset fp rehash
}