summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff M. Hubbard2019-01-13 10:45:40 -0600
committerJeff M. Hubbard2019-01-13 10:45:40 -0600
commit37d788a9be03d5f1b4299ffd0e949be5ec2d7e3c (patch)
treed6d4c66286a3eccd9e27ce6290a716016550e66c
parentdfc0442f441bd32ea9dfb21dcf663611960a1e47 (diff)
downloadaur-37d788a9be03d5f1b4299ffd0e949be5ec2d7e3c.tar.gz
Update for latest revision, better PKGBUILD
-rw-r--r--.SRCINFO5
-rwxr-xr-xPKGBUILD14
-rw-r--r--mpnotd.install2
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7f53a65625e..fb7188d5d37f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpnotd-git
pkgdesc = MPD Notification Daemon
- pkgver = r4.613c1f4
+ pkgver = r10.daf63c2
pkgrel = 1
url = https://github.com/jeffmhubbard/mpnotd
install = mpnotd.install
@@ -14,7 +14,8 @@ pkgbase = mpnotd-git
depends = python-mpd2
depends = python-notify2
depends = python-beautifulsoup4
- optdepends = dunst: Display notifications
+ depends = python-pillow
+ optdepends = dunst: display notifications
source = mpnotd::git+https://github.com/jeffmhubbard/mpnotd.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4a83bd26f78a..8421830291a3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Jeff M. Hubbard <jeffmhubbard@gmail.com>
_pkgname=mpnotd
pkgname=${_pkgname}-git
-pkgver=r4.613c1f4
+pkgver=r10.daf63c2
pkgrel=1
pkgdesc="MPD Notification Daemon"
arch=('any')
url="https://github.com/jeffmhubbard/mpnotd"
license=('MIT')
-depends=('mpd' 'python' 'python-mpd2' 'python-notify2' 'python-beautifulsoup4')
-makedepends=('git' 'sed' 'grep')
-optdepends=('dunst: Display notifications')
+depends=('mpd' 'python' 'python-mpd2' 'python-notify2' 'python-beautifulsoup4' 'python-pillow')
+makedepends=('git')
+optdepends=('dunst: display notifications')
conflicts=()
source=("${_pkgname}::git+${url}.git")
md5sums=("SKIP")
@@ -22,11 +22,15 @@ pkgver() {
package() {
mkdir -p $pkgdir/usr/bin
- cp "$srcdir/$_pkgname/$_pkgname" $pkgdir/usr/bin/$_pkgname
+ install -Dm 755 "$srcdir/$_pkgname/$_pkgname" $pkgdir/usr/bin/$_pkgname
if [[ $(pidof systemd) ]]; then
_serviceloc="$pkgdir/usr/lib/systemd/user"
mkdir -p "$_serviceloc"
_servicename="$_pkgname.service"
cp "$srcdir/$_pkgname/$_servicename" "$_serviceloc/$_servicename"
fi
+ _docloc="$pkgdir/usr/share/doc/mpnotd"
+ mkdir -p $_docloc
+ cp "$srcdir/$_pkgname/README.md" $_docloc
+ cp "$srcdir/$_pkgname/LICENSE" $_docloc
}
diff --git a/mpnotd.install b/mpnotd.install
index a83b3c77f755..ab64cde94323 100644
--- a/mpnotd.install
+++ b/mpnotd.install
@@ -2,7 +2,7 @@ post_install() {
echo "For config, run: mpnotd --writeini"
if [[ $(pidof systemd) ]]; then
echo "Systemd service installed, to enable type:"
- echo "sudo systemctl --user enable mpnotd.service"
+ echo "systemctl --user enable mpnotd"
fi
}