summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff M. Hubbard2019-01-01 10:24:10 -0600
committerJeff M. Hubbard2019-01-01 10:24:10 -0600
commitdfc0442f441bd32ea9dfb21dcf663611960a1e47 (patch)
tree66f970fe662056e5420ed69c3b4c4025ae759285
downloadaur-dfc0442f441bd32ea9dfb21dcf663611960a1e47.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD32
-rw-r--r--mpnotd.install11
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7f53a65625e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mpnotd-git
+ pkgdesc = MPD Notification Daemon
+ pkgver = r4.613c1f4
+ pkgrel = 1
+ url = https://github.com/jeffmhubbard/mpnotd
+ install = mpnotd.install
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = sed
+ makedepends = grep
+ depends = mpd
+ depends = python
+ depends = python-mpd2
+ depends = python-notify2
+ depends = python-beautifulsoup4
+ optdepends = dunst: Display notifications
+ source = mpnotd::git+https://github.com/jeffmhubbard/mpnotd.git
+ md5sums = SKIP
+
+pkgname = mpnotd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4a83bd26f78a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jeff M. Hubbard <jeffmhubbard@gmail.com>
+_pkgname=mpnotd
+pkgname=${_pkgname}-git
+pkgver=r4.613c1f4
+pkgrel=1
+pkgdesc="MPD Notification Daemon"
+arch=('any')
+url="https://github.com/jeffmhubbard/mpnotd"
+license=('MIT')
+depends=('mpd' 'python' 'python-mpd2' 'python-notify2' 'python-beautifulsoup4')
+makedepends=('git' 'sed' 'grep')
+optdepends=('dunst: Display notifications')
+conflicts=()
+source=("${_pkgname}::git+${url}.git")
+md5sums=("SKIP")
+install=${_pkgname}.install
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp "$srcdir/$_pkgname/$_pkgname" $pkgdir/usr/bin/$_pkgname
+ if [[ $(pidof systemd) ]]; then
+ _serviceloc="$pkgdir/usr/lib/systemd/user"
+ mkdir -p "$_serviceloc"
+ _servicename="$_pkgname.service"
+ cp "$srcdir/$_pkgname/$_servicename" "$_serviceloc/$_servicename"
+ fi
+}
diff --git a/mpnotd.install b/mpnotd.install
new file mode 100644
index 000000000000..a83b3c77f755
--- /dev/null
+++ b/mpnotd.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "For config, run: mpnotd --writeini"
+ if [[ $(pidof systemd) ]]; then
+ echo "Systemd service installed, to enable type:"
+ echo "sudo systemctl --user enable mpnotd.service"
+ fi
+}
+
+post_upgrade() {
+ post_install
+}