summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-04-13 06:18:40 -0400
committergraysky2019-04-13 06:18:40 -0400
commit0082aac282f5fd051d9d16e8c3b687653bc2a5a9 (patch)
treed1b7717d6d4a27192edc93ebfd5c67b0e3c5cacc
parent7353eef9e7c6f58fa0cfd26d97abd5bb7013f49c (diff)
downloadaur-0082aac282f5fd051d9d16e8c3b687653bc2a5a9.tar.gz
Update to 298b1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--unfuck_makefile.patch13
3 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 000441b2558f..41512785f766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Thu Apr 12 18:10:05 UTC 2018
+# Sat Apr 13 10:18:40 UTC 2019
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
- pkgver = 294b7
- pkgrel = 4
+ pkgver = 298b1
+ pkgrel = 1
url = http://www.mersenne.org
arch = x86_64
license = custom
depends = curl
- depends = hwloc
+ depends = hwloc>2.0.3
conflicts = mprime-bin
- source = http://www.mersenne.org/ftp_root/gimps/p95v294b7.source.zip
+ source = http://www.mersenne.org/ftp_root/gimps/p95v298b1.source.zip
source = unfuck_makefile.patch
- sha256sums = 15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45
- sha256sums = c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528
+ sha256sums = 8e008d28acddcafe7b44ea9e6c6ef5b297bffddfe9969f8154bc6812d3336a11
+ sha256sums = b9eb3e4009c072341df0814366ff4ba69951bf7642e9d122d0d2be383c85c9fd
pkgname = mprime
diff --git a/PKGBUILD b/PKGBUILD
index 0fae44fad609..3bb744fd6470 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
pkgname=mprime
-pkgver=294b7
-pkgrel=4
+pkgver=298b1
+pkgrel=1
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
arch=('x86_64')
url="http://www.mersenne.org"
license=('custom')
-depends=('curl' 'hwloc')
+depends=('curl' 'hwloc>2.0.3')
conflicts=('mprime-bin')
source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip"
unfuck_makefile.patch)
-sha256sums=('15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45'
- 'c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528')
+sha256sums=('8e008d28acddcafe7b44ea9e6c6ef5b297bffddfe9969f8154bc6812d3336a11'
+ 'b9eb3e4009c072341df0814366ff4ba69951bf7642e9d122d0d2be383c85c9fd')
prepare () {
patch -Np1 -i unfuck_makefile.patch
diff --git a/unfuck_makefile.patch b/unfuck_makefile.patch
index c62a20827412..cbc57ebc4f0e 100644
--- a/unfuck_makefile.patch
+++ b/unfuck_makefile.patch
@@ -1,14 +1,13 @@
-diff --git a/linux64/makefile b/linux64/makefile
-index 329cb51..88acbc6 100644
---- a/linux64/makefile
-+++ b/linux64/makefile
-@@ -20,15 +20,15 @@
+--- a/linux64/makefile 2019-03-26 16:57:56.000000000 -0400
++++ b/linux64/makefile 2019-04-12 13:27:06.283044502 -0400
+@@ -20,15 +20,17 @@
# LFLAGS = -Wl,-M
# LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
+MPRIME_FLAGS=-I.. -I../gwnum -DX86_64 -march=x86-64 -O2 -Wno-unused-result
++
CC = gcc
--CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2
+-CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -Wno-unused-result -O2
+CFLAGS = ${MPRIME_FLAGS}
CPP = g++
@@ -16,7 +15,7 @@ index 329cb51..88acbc6 100644
+CPPFLAGS = ${MPRIME_FLAGS}
LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
--#LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+ #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp