summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2017-10-18 15:24:54 -0400
committergraysky2017-10-18 15:24:54 -0400
commit089efd56e09178bf69397479079c875aea469bd9 (patch)
tree3c76c2c37a024a767a12df0f1aa174e46b99067b
parentbc91d9163b4c87d9c77ce2de7271ee03ce070f6f (diff)
downloadaur-089efd56e09178bf69397479079c875aea469bd9.tar.gz
Update to 293-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--unfuck_makefile.patch19
3 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da4601405d09..a2571f4892e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sat May 13 10:41:54 UTC 2017
+# Wed Oct 18 19:24:54 UTC 2017
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
- pkgver = 291
- pkgrel = 5
+ pkgver = 293
+ pkgrel = 1
url = http://www.mersenne.org
arch = x86_64
license = custom
depends = curl
depends = hwloc
conflicts = mprime-bin
- source = http://www.mersenne.org/ftp_root/gimps/p95v291.source.zip
+ source = http://www.mersenne.org/ftp_root/gimps/p95v293.source.zip
source = unfuck_makefile.patch
- sha256sums = b2af302d423765e1f053731f4c0dac6983a9598eb1b16fcf6159491dbb1c3972
- sha256sums = c956812ed5f07c8f2f30c906734971f286558ff6267a0c2dfa602e1798e0cef9
+ sha256sums = da6c73286a8736e6d7a9108441fd2b4628f670988e2340b22b6c4c4d3e374df5
+ sha256sums = c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528
pkgname = mprime
diff --git a/PKGBUILD b/PKGBUILD
index cd3f5af48bd7..00d7dc013e9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
pkgname=mprime
-pkgver=291
-pkgrel=5
+pkgver=293
+pkgrel=1
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
arch=('x86_64')
url="http://www.mersenne.org"
@@ -13,8 +13,8 @@ depends=('curl' 'hwloc')
conflicts=('mprime-bin')
source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip"
unfuck_makefile.patch)
-sha256sums=('b2af302d423765e1f053731f4c0dac6983a9598eb1b16fcf6159491dbb1c3972'
- 'c956812ed5f07c8f2f30c906734971f286558ff6267a0c2dfa602e1798e0cef9')
+sha256sums=('da6c73286a8736e6d7a9108441fd2b4628f670988e2340b22b6c4c4d3e374df5'
+ 'c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528')
prepare () {
patch -Np1 -i unfuck_makefile.patch
diff --git a/unfuck_makefile.patch b/unfuck_makefile.patch
index b99034e0f19d..c62a20827412 100644
--- a/unfuck_makefile.patch
+++ b/unfuck_makefile.patch
@@ -1,19 +1,24 @@
---- a/linux64/makefile 2017-03-18 21:18:04.000000000 -0400
-+++ b/linux64/makefile 2017-03-20 09:38:23.273509623 -0400
-@@ -21,13 +21,13 @@
+diff --git a/linux64/makefile b/linux64/makefile
+index 329cb51..88acbc6 100644
+--- a/linux64/makefile
++++ b/linux64/makefile
+@@ -20,15 +20,15 @@
+ # LFLAGS = -Wl,-M
# LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
++MPRIME_FLAGS=-I.. -I../gwnum -DX86_64 -march=x86-64 -O2 -Wno-unused-result
CC = gcc
-CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2
-+CFLAGS = -I.. -I../gwnum -march=x86-64 -DX86_64 -O2 -Wno-unused-result
++CFLAGS = ${MPRIME_FLAGS}
CPP = g++
-CPPFLAGS = -I.. -I../gwnum -DX86_64 -O2
-+CPPFLAGS = -I.. -I../gwnum -march=x86-64 -O2 -Wno-unused-result
++CPPFLAGS = ${MPRIME_FLAGS}
LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
--LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl
-+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc)
+-#LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
FACTOROBJ = factor64.o
LINUXOBJS = prime.o menu.o