summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 18:01:39 -0400
committergraysky2015-06-08 18:01:39 -0400
commit44617871279f9529f3d7cd28ee2eca4d988030cd (patch)
treebd036d5f42764eb166cffdac8e17ec0c005ea682
downloadaur-44617871279f9529f3d7cd28ee2eca4d988030cd.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
-rw-r--r--unfuck_makefile.patch34
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6d789058187
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mprime
+ pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
+ pkgver = 287
+ pkgrel = 1
+ url = http://www.mersenne.org
+ arch = x86_64
+ license = custom
+ depends = curl
+ source = http://www.mersenneforum.org/gimps/p95v287.source.zip
+ source = unfuck_makefile.patch
+ sha256sums = a2053861b15d48f931fa9587621b7da285beacda38cd9e8bb77709eeb6c6d251
+ sha256sums = acd0c109fcc1f6e08de248992b16649802d94e7b15fdfe170b73413adfc3755c
+
+pkgname = mprime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae726fbd59d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+# Contributer: xyne <xyne AT archlinux DOT ca>
+# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
+
+pkgname=mprime
+pkgver=287
+pkgrel=1
+pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
+arch=('x86_64')
+url="http://www.mersenne.org"
+license=('custom')
+depends=('curl')
+source=("http://www.mersenneforum.org/gimps/p95v${pkgver}.source.zip"
+unfuck_makefile.patch)
+sha256sums=('a2053861b15d48f931fa9587621b7da285beacda38cd9e8bb77709eeb6c6d251'
+ 'acd0c109fcc1f6e08de248992b16649802d94e7b15fdfe170b73413adfc3755c')
+
+prepare () {
+ patch -Np1 -i unfuck_makefile.patch
+}
+
+build() {
+ cd "$srcdir/gwnum"
+ make -f make64
+
+ cd "$srcdir/linux64"
+ make
+}
+
+package() {
+ install -Dm755 linux64/mprime "$pkgdir/usr/bin/mprime"
+
+ # license and documentation
+ # x86_64 tarball for 279 includes none of these
+ #install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ #install -Dm644 readme.txt "$pkgdir/usr/share/doc/$pkgname/readme.txt"
+ #install -Dm644 stress.txt "$pkgdir/usr/share/doc/$pkgname/stress.txt"
+ #install -Dm644 undoc.txt "$pkgdir/usr/share/doc/$pkgname/undoc.txt"
+ #install -Dm644 whatsnew.txt "$pkgdir/usr/share/doc/$pkgname/whatsnew.txt"
+}
diff --git a/unfuck_makefile.patch b/unfuck_makefile.patch
new file mode 100644
index 000000000000..20ce198b69e2
--- /dev/null
+++ b/unfuck_makefile.patch
@@ -0,0 +1,34 @@
+--- a/gwnum/makefile 2014-05-29 22:35:10.000000000 -0400
++++ b/gwnum/makefile 2014-10-09 05:37:38.505853864 -0400
+@@ -2,10 +2,10 @@
+ #
+
+ CC = gcc
+-CFLAGS = -I.. -O2 -march=i486 -malign-double
++CFLAGS = -I.. -O2 -march=x86-64 -mtune=generic -malign-double
+
+ CPP = g++
+-CPPFLAGS = -I.. -I../qd -O2 -march=i486 -malign-double
++CPPFLAGS = -I.. -I../qd -O2 -march=x86-64 -mtune=generic -malign-double
+
+ OBJS = cpuid.o gwnum.o gwtables.o gwthread.o gwutil.o gwdbldbl.o giants.o ecmstag1.o
+
+--- a/linux64/makefile 2014-05-29 22:35:16.000000000 -0400
++++ b/linux64/makefile 2014-10-09 05:42:54.648403900 -0400
+@@ -13,13 +13,13 @@
+ # LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
+
+ CC = gcc
+-CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2
++CFLAGS = -I.. -I../gwnum -march=x86-64 -mtune=generic -O2 -DX86_64 -malign-double -Wno-unused-result
+
+ CPP = g++
+-CPPFLAGS = -I.. -I../gwnum -DX86_64 -O2
++CPPFLAGS = -I.. -I../gwnum -march=x86-64 -mtune=generic -O2 -DX86_64 -malign-double -Wno-unused-result
+
+ LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++
+
+ FACTOROBJ = factor64.o
+ LINUXOBJS = prime.o menu.o