summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2022-09-24 14:18:55 -0400
committergraysky2022-09-24 14:18:55 -0400
commit924925a4e78b89e03343f74bdb54acd9b6bac2ac (patch)
tree631320a59211d62015a856d784cfbd6f72d6d079
parenta54594f1af6aba0a965d8a4a95502d455e6e32aa (diff)
downloadaur-924925a4e78b89e03343f74bdb54acd9b6bac2ac.tar.gz
Update to 30.8-1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-makefile-fix-build-for-Arch-Linux.patch46
-rw-r--r--PKGBUILD11
3 files changed, 36 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 538aa04616c5..31ae56f88a73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
- pkgver = 307b9
- pkgrel = 2
+ pkgver = 30.8
+ pkgrel = 1
url = http://www.mersenne.org
arch = x86_64
license = custom
@@ -10,9 +10,9 @@ pkgbase = mprime
depends = hwloc
depends = boost-libs
conflicts = mprime-bin
- source = http://www.mersenne.org/ftp_root/gimps/p95v307b9.source.zip
+ source = http://www.mersenne.org/ftp_root/gimps/p95v308b15.source.zip
source = 0001-makefile-fix-build-for-Arch-Linux.patch
- b2sums = 0902ffb2263fc1da4f4dd17daceaeff211370e3552b9d5d411721fa3d567c36b822cccda85a10262ca5ca162f83066574a45ab2ec7c6277f63d2099c8cc5d85a
- b2sums = e80b00415ae4dddc03213ddacdb37161984a9c07be2e2a0ed6210c2f9cbe293c74f74c39a1ea81a15d2db502654fbf174cf5adf5839dfba98d8e2c4669d8d814
+ b2sums = 9ec5da2125b62630da84cad91b2293403fbdc9d86eb3b03a3b943256417f816cdfff1d8c5af9f6e7604c5cc628c65c13161437e19468985b7b037562fc1050da
+ b2sums = 8b6f218b70d89d76b555e0955d480e7112279dd87f8f6101dd10eaf9b8de846d9fd469a7ba0ba7685ed68aa40fff240e0c7a9002380e4482ddf44d69b285587c
pkgname = mprime
diff --git a/0001-makefile-fix-build-for-Arch-Linux.patch b/0001-makefile-fix-build-for-Arch-Linux.patch
index 1c141b85ba73..5e3e2a481965 100644
--- a/0001-makefile-fix-build-for-Arch-Linux.patch
+++ b/0001-makefile-fix-build-for-Arch-Linux.patch
@@ -1,37 +1,41 @@
-From 3ee9ae9b0c8efdb356e53a7d36373e906de02f9d Mon Sep 17 00:00:00 2001
-From: graysky <graysky@archlinux.us>
-Date: Tue, 30 Nov 2021 06:27:15 -0500
+From da7641d4be383e1170ab39bc162480cb1836591e Mon Sep 17 00:00:00 2001
+From: graysky <therealgraysky AT proton DOT me>
+Date: Sat, 24 Sep 2022 14:12:44 -0400
Subject: [PATCH] makefile: fix build for Arch Linux
+Fix up for Arch Linux build. Thanks to Prime95 for the tip around polymult.a lib[1].
+
+1. https://www.mersenneforum.org/showthread.php?t=28094
+
---
- linux64/makefile | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
+ linux64/makefile | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/linux64/makefile b/linux64/makefile
-index f73ba4f..4ba2517 100644
+index 420801f..a319fc1 100644
--- a/linux64/makefile
+++ b/linux64/makefile
@@ -18,15 +18,17 @@
# LFLAGS = -Wl,-M
# LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
-
-+MPRIME_FLAGS= -I.. -I../gwnum -DX86_64 -O2 -Wno-unused-result -march=x86-64 -DPORT=8
+
++ALFLAGS = -I.. -I../gwnum -march=x86-64 -DX86_64 -O2 -Wno-unused-result -march=x86-64 -DPORT=8
+
CC = gcc
-CFLAGS = -I.. -I../gwnum -I/usr/local/include -std=gnu99 -DX86_64 -Wno-unused-result -O2 -DPORT=8
-+CFLAGS = ${MPRIME_FLAGS} -std=gnu99
-
++CFLAGS = ${ALFLAGS}
+
CPP = g++
-CPPFLAGS = -I.. -I../gwnum -I../../boost_1_76_0 -DX86_64 -std=c++11 -O2 -DPORT=8
-+CPPFLAGS = ${MPRIME_FLAGS} -std=c++11
-
- LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
- #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
--LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
-+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
-
- FACTOROBJ = factor64.o
- LINUXOBJS = prime.o menu.o cJSON.o ecm.o pair.o pm1prob.o
---
-2.34.1
++CPPFLAGS = ${ALFLAGS} -std=c++11
+
+-LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
++LFLAGS = -Wl,-M
+ #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
++LIBS= ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
+ FACTOROBJ = factor64.o
+ LINUXOBJS = prime.o menu.o cJSON.o ecm.o exponentiate.o pair.o pm1prob.o
+--
+2.37.3
diff --git a/PKGBUILD b/PKGBUILD
index c7db09c7ea5b..ae95f8e913c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
pkgname=mprime
-pkgver=307b9
-pkgrel=2
+pkgver=30.8
+_pkgver=308b15
+pkgrel=1
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
arch=(x86_64)
url="http://www.mersenne.org"
@@ -12,10 +13,10 @@ license=('custom')
depends=(curl hwloc boost-libs)
makedepends=(boost)
conflicts=(mprime-bin)
-source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip"
+source=("http://www.mersenne.org/ftp_root/gimps/p95v${_pkgver}.source.zip"
0001-makefile-fix-build-for-Arch-Linux.patch)
-b2sums=('0902ffb2263fc1da4f4dd17daceaeff211370e3552b9d5d411721fa3d567c36b822cccda85a10262ca5ca162f83066574a45ab2ec7c6277f63d2099c8cc5d85a'
- 'e80b00415ae4dddc03213ddacdb37161984a9c07be2e2a0ed6210c2f9cbe293c74f74c39a1ea81a15d2db502654fbf174cf5adf5839dfba98d8e2c4669d8d814')
+b2sums=('9ec5da2125b62630da84cad91b2293403fbdc9d86eb3b03a3b943256417f816cdfff1d8c5af9f6e7604c5cc628c65c13161437e19468985b7b037562fc1050da'
+ '8b6f218b70d89d76b555e0955d480e7112279dd87f8f6101dd10eaf9b8de846d9fd469a7ba0ba7685ed68aa40fff240e0c7a9002380e4482ddf44d69b285587c')
prepare () {
patch -Np1 -i 0001-makefile-fix-build-for-Arch-Linux.patch