summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhxss2020-12-05 23:36:06 +0300
committerhxss2020-12-05 23:36:06 +0300
commit814d3506092a643c4359ebe5016960cd89ae464d (patch)
treef89d074c32d078d2860e7846a07276fb609dfb98
downloadaur-814d3506092a643c4359ebe5016960cd89ae464d.tar.gz
init commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--INSTALL9
-rw-r--r--PKGBUILD15
-rw-r--r--mpris-proxy.service11
5 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18b956eac41d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = mpris-proxy-service
+ pkgdesc = mpris-proxy systemd service
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.bluez.org/
+ install = INSTALL
+ arch = any
+ depends = bluez-utils
+
+pkgname = mpris-proxy-service
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d8c60bcb3da
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+.project/
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 000000000000..1e3dfe6e4030
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo
+ echo Usage:
+ echo
+ echo systemctl --user start mpris-proxy
+ echo systemctl --user enable mpris-proxy
+ echo
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2000b94d8097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Sergey Khobta <hxss@ya.ru>
+
+pkgname=mpris-proxy-service
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="mpris-proxy systemd service"
+arch=(any)
+url="http://www.bluez.org/"
+depends=("bluez-utils")
+install='INSTALL'
+
+package() {
+ install -Dm644 ../mpris-proxy.service \
+ -t "$pkgdir/usr/lib/systemd/user"
+}
diff --git a/mpris-proxy.service b/mpris-proxy.service
new file mode 100644
index 000000000000..3ca16335d22c
--- /dev/null
+++ b/mpris-proxy.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Forward bluetooth midi controls via mpris2 so they are picked up by supporting media players
+Requires=dbus.service bluetooth.target
+After=dbus.service bluetooth.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/mpris-proxy
+
+[Install]
+WantedBy=default.target