summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kobel2016-02-12 13:27:09 +0100
committerAlexander Kobel2016-02-12 13:27:09 +0100
commit67450aa15aaf329eb466398b0f56b988f0880d07 (patch)
tree1da3fe3aa799971119cd945ace2e3ce36496803b
downloadaur-67450aa15aaf329eb466398b0f56b988f0880d07.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a1be442ca51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 5.0.0
+# Fri Feb 12 12:22:56 UTC 2016
+pkgbase = mpsolve
+ pkgdesc = Multiprecision rootfinder for complex roots of univariate polynomials
+ pkgver = 3.1.4
+ pkgrel = 1
+ url = http://numpi.dm.unipi.it/software/mpsolve
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gmp
+ depends = mpfr
+ optdepends = cython: Python bindings
+ optdepends = gtk3: Graphical debugger
+ optdepends = octave: Octave bindings
+ optdepends = qt4: Graphical interface xmpsolve
+ source = http://numpi.dm.unipi.it/_media/software/mpsolve/mpsolve-3.1.4.tar.bz2
+ sha256sums = c6ea3774bbcb50865f65426761e398861bc448697c563bcd46e551c81c4f70ad
+
+pkgname = mpsolve
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fac1b20efe5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander Kobel <a-kobel@a-kobel.de>
+
+pkgname=mpsolve
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="Multiprecision rootfinder for complex roots of univariate polynomials"
+url="http://numpi.dm.unipi.it/software/mpsolve"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gmp' 'mpfr')
+optdepends=('cython: Python bindings'
+ 'gtk3: Graphical debugger'
+ 'octave: Octave bindings'
+ 'qt4: Graphical interface xmpsolve')
+source=("http://numpi.dm.unipi.it/_media/software/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('c6ea3774bbcb50865f65426761e398861bc448697c563bcd46e551c81c4f70ad')
+
+build () {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ sed -e "s/$(echo "${pkgdir}" | sed -e 's/[\/&]/\\&/g')//g" -i ${pkgdir}/usr/share/octave/octave_packages
+}