summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kobel2021-02-08 18:10:56 +0100
committerAlexander Kobel2021-02-08 18:10:56 +0100
commit78a7289ebce138b5e5cb0796e8531b4eefe88321 (patch)
treec966073d21b8e00df3a19dad5d5b60559607b3a0
parente3baaf6f945dd82dbc11c1b1d53a13e593f8b89e (diff)
downloadaur-78a7289ebce138b5e5cb0796e8531b4eefe88321.tar.gz
Stop building outdated examples (octave)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 5 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0cff724d721..a3c4fc9c9d62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mpsolve
pkgdesc = Multiprecision rootfinder for complex roots of univariate polynomials
pkgver = 3.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://numpi.dm.unipi.it/software/mpsolve
arch = x86_64
license = GPL
@@ -11,13 +11,10 @@ pkgbase = mpsolve
optdepends = cython: Python bindings
optdepends = doxygen: documentation (optional build-time dependency)
optdepends = gtk3: Graphical debugger
- optdepends = octave: Octave bindings
optdepends = qt5-base: Graphical interface xmpsolve
options = !libtool
source = http://numpi.dm.unipi.it/_media/software/mpsolve/mpsolve-3.2.1.tar.bz2
- source = https://raw.githubusercontent.com/robol/MPSolve/master/examples/octave/octave_support.h
sha256sums = 45b22f6b04544b9eda2457eec58580d892c7e00824ebd2d6e31fe24cdd763804
- sha256sums = d88d5e982b11512e7e2af82db89f0481759d9c50c27d9c8261220bd1b508f136
pkgname = mpsolve
diff --git a/PKGBUILD b/PKGBUILD
index aa7437062a48..5d3b3ce663f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mpsolve
pkgver=3.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Multiprecision rootfinder for complex roots of univariate polynomials"
url="http://numpi.dm.unipi.it/software/mpsolve"
arch=('x86_64')
@@ -12,18 +12,14 @@ makedepends=('gcc-fortran')
optdepends=('cython: Python bindings'
'doxygen: documentation (optional build-time dependency)'
'gtk3: Graphical debugger'
- 'octave: Octave bindings'
'qt5-base: Graphical interface xmpsolve')
options=(!libtool)
-source=("http://numpi.dm.unipi.it/_media/software/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
- "https://raw.githubusercontent.com/robol/MPSolve/master/examples/octave/octave_support.h")
-sha256sums=('45b22f6b04544b9eda2457eec58580d892c7e00824ebd2d6e31fe24cdd763804'
- 'd88d5e982b11512e7e2af82db89f0481759d9c50c27d9c8261220bd1b508f136')
+source=("http://numpi.dm.unipi.it/_media/software/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('45b22f6b04544b9eda2457eec58580d892c7e00824ebd2d6e31fe24cdd763804')
build () {
cd "${srcdir}/${pkgname}-${pkgver}"
- ln -sf ../../../octave_support.h examples/octave/
- ./configure --prefix=/usr --disable-debug
+ ./configure --prefix=/usr --disable-debug --disable-examples
make
}
@@ -36,10 +32,6 @@ package () {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- if [ -f "${pkgdir}/usr/share/octave/octave_packages" ]; then
- sed -e "s/$(echo "${pkgdir}" | sed -e 's/[\/&]/\\&/g')//g" -i "${pkgdir}/usr/share/octave/octave_packages"
- fi
-
if [ -e doc/html ]; then
cd doc/html
find . -type f -exec install -D -m644 "{}" "${pkgdir}/usr/share/doc/${pkgname}/{}" \;