aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Huber2016-08-19 09:29:05 +0200
committerMarcel Huber2016-08-19 09:29:05 +0200
commitc8517e803ef52c2e8524b23d64eaa0022aff0612 (patch)
tree43f24feb6b660eb0f55e017b7a6ed2c038f72eab
parentd8d5d5c641ea21286d12683675106752667cdc5e (diff)
downloadaur-c8517e803ef52c2e8524b23d64eaa0022aff0612.tar.gz
patch kernel module Makefile to build for dkms kernelversion
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mpss-modules-Makefile.patch36
3 files changed, 42 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c4523e0e2a1..8c81ddb8dd0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mpss
pkgdesc = IntelĀ® Manycore Platform Software Stack
pkgver = 3.7.1
- pkgrel = 8
+ pkgrel = 9
url = https://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss
arch = x86_64
license = LGPL2.1
@@ -25,6 +25,7 @@ pkgbase = mpss
source = mpss-modules-init-indent.patch
source = mpss-modules-rcu-lockup.patch
source = mpss-modules-page-cache.patch
+ source = mpss-modules-Makefile.patch
source = mpss-gen-symver-map-python3-compat.patch
source = mpss-micmgmt-misleading-indent.patch
source = mpss-micmgmt-remove-inline0.patch
@@ -44,6 +45,7 @@ pkgbase = mpss
sha256sums = b1264678b77a3ae64716e507e225fce5cfd1c77ae77d0119071c28cab74d0a97
sha256sums = 3690295e9e24e6a8b42323ca5b2b76f56a3a8f4bdee75b3dfc5a3f01e3f3d1bc
sha256sums = ace053c75b096c2e120c73076c9a86fcbf1528518761766b9e41e975dc44ae43
+ sha256sums = 565d86b880c0dbdd6c0a37383264175f0e3f74db45efa7dac166191ac129e44c
sha256sums = 17791147eef797e4fe161bb08e989685303dbff866d01f2e37335c09e6367688
sha256sums = 64d26ff84029d246868f995cf9fd49b20851a671208c3fa474e0fef5216708cd
sha256sums = 99d0e6d58a14bfbbe96b41de8f0f4383225acaefba8e4d48c7ff86924502c545
diff --git a/PKGBUILD b/PKGBUILD
index 6766d415ad0b..ff9551e96aff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=(
)
pkgdesc="IntelĀ® Manycore Platform Software Stack"
pkgver=3.7.1
-pkgrel=8
+pkgrel=9
arch=('x86_64')
url="https://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss"
license=('LGPL2.1')
@@ -31,6 +31,7 @@ source=(
mpss-modules-init-indent.patch
mpss-modules-rcu-lockup.patch
mpss-modules-page-cache.patch
+ mpss-modules-Makefile.patch
mpss-gen-symver-map-python3-compat.patch
mpss-micmgmt-misleading-indent.patch
mpss-micmgmt-remove-inline0.patch
@@ -51,6 +52,7 @@ sha256sums=('3a8d070d7b82d41afa67766db8e3305621643ced1b3f8e2845bf333cdf39b83b'
'b1264678b77a3ae64716e507e225fce5cfd1c77ae77d0119071c28cab74d0a97'
'3690295e9e24e6a8b42323ca5b2b76f56a3a8f4bdee75b3dfc5a3f01e3f3d1bc'
'ace053c75b096c2e120c73076c9a86fcbf1528518761766b9e41e975dc44ae43'
+ '565d86b880c0dbdd6c0a37383264175f0e3f74db45efa7dac166191ac129e44c'
'17791147eef797e4fe161bb08e989685303dbff866d01f2e37335c09e6367688'
'64d26ff84029d246868f995cf9fd49b20851a671208c3fa474e0fef5216708cd'
'99d0e6d58a14bfbbe96b41de8f0f4383225acaefba8e4d48c7ff86924502c545'
diff --git a/mpss-modules-Makefile.patch b/mpss-modules-Makefile.patch
new file mode 100644
index 000000000000..954c78f2831d
--- /dev/null
+++ b/mpss-modules-Makefile.patch
@@ -0,0 +1,36 @@
+From 58202e4cbdce40e3bf7352b64e293d3f0d4f853b Mon Sep 17 00:00:00 2001
+From: Marcel Huber <marcelhuberfoo@gmail.com>
+Date: Fri, 19 Aug 2016 09:27:06 +0200
+Subject: replace KERNEL_VERSION with KERNELRELEASE
+
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git mpss-modules/Makefile mpss-modules/Makefile
+index 42dd454..9c13aa3 100644
+--- mpss-modules/Makefile
++++ mpss-modules/Makefile
+@@ -42,8 +42,8 @@ export MPSS_BUILDNO := $(MPSS_BUILDNO)
+ export MPSS_BUILTBY := $(shell echo "`whoami`@`uname -n`")
+ export MPSS_BUILTON := $(shell date +'%F %T %z')
+
+-KERNEL_VERSION := $(shell uname -r)
+-KERNEL_SRC = /lib/modules/$(KERNEL_VERSION)/build
++KERNELRELEASE := $(shell uname -r)
++KERNEL_SRC = /lib/modules/$(KERNELRELEASE)/build
+
+ INSTALL = install
+ INSTALL_d = $(INSTALL) -d
+@@ -54,7 +54,7 @@ prefix = /usr/local
+ sysconfdir = $(prefix)/etc
+ includedir = $(prefix)/include
+
+-kmodinstalldir = /lib/modules/$(KERNEL_VERSION)
++kmodinstalldir = /lib/modules/$(KERNELRELEASE)
+ kmodincludedir = $(realpath $(KERNEL_SRC))/include/modules
+
+ # If building the host's driver for a MIC co-processor card, which card
+--
+2.9.3
+