summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2018-04-18 17:10:19 +1000
committerWesley Moore2018-04-18 17:11:25 +1000
commit595d58ca14a0db1cc2a57ebc695118ed666d4c1f (patch)
tree1ac49396670063ae47320d453a61e3ac3564d466
downloadaur-595d58ca14a0db1cc2a57ebc695118ed666d4c1f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD25
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c082cfa3e7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mpssh
+ pkgdesc = Mass Parallel SSH
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = https://github.com/ndenev/mpssh
+ arch = x86_64
+ arch = i686
+ license = custom:BSD
+ source = https://github.com/ndenev/mpssh/archive/1.3.3.tar.gz
+ source = LICENSE
+ sha1sums = ba11dfe7607cac3d47f1c86db236a2e440700ce7
+ sha1sums = 298a1f1087f2483005cba2878acd17eb8c3bf94c
+
+pkgname = mpssh
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..04a2875b955b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Copyright: 2005-2015 Nikolay Denev <ndenev@gmail.com>
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. The name of the author may not be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..822612859bfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Wesley Moore <wes@wezm.net>
+
+pkgname=mpssh
+pkgver=1.3.3
+pkgrel=1
+pkgdesc='Mass Parallel SSH'
+arch=(x86_64 i686)
+url='https://github.com/ndenev/mpssh'
+license=('custom:BSD')
+depends=('openssh')
+optdepends=()
+source=("${url}/archive/${pkgver}.tar.gz"
+ 'LICENSE')
+sha1sums=('ba11dfe7607cac3d47f1c86db236a2e440700ce7'
+ '298a1f1087f2483005cba2878acd17eb8c3bf94c')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/mpssh" "$pkgdir/usr/bin/mpssh"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}