summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigitalone2019-04-10 17:25:16 +0200
committerdigitalone2019-04-10 17:25:16 +0200
commitdb01665d2d974027ad68e0c8b148fcfeaab7f74b (patch)
tree3aab90cd7d0a5d137fc203b70f7ab66c0967dbfe
downloadaur-db01665d2d974027ad68e0c8b148fcfeaab7f74b.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--mpv-acestream.install29
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f535c450ce1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mpv-acestream
+ pkgdesc = Lua script that adds AceStream protocol handler to mpv player
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Digitalone1/mpv-acestream
+ install = mpv-acestream.install
+ arch = any
+ license = GPL3
+ optdepends = acestream-engine: AceStream engine
+ source = https://github.com/Digitalone1/mpv-acestream/archive/v0.1.tar.gz
+ md5sums = 14defb5825819786c86bf25a1a054cdc
+
+pkgname = mpv-acestream
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ff59da99e01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Giusy Margarita <kurmikon at libero dot it>
+
+pkgname=mpv-acestream
+pkgver=0.1
+pkgrel=1
+pkgdesc="Lua script that adds AceStream protocol handler to mpv player"
+arch=("any")
+url="https://github.com/Digitalone1/mpv-acestream"
+license=("GPL3")
+#depends=()
+#makedepends=()
+optdepends=("acestream-engine: AceStream engine")
+source=("https://github.com/Digitalone1/mpv-acestream/archive/v$pkgver.tar.gz")
+install="$pkgname.install"
+md5sums=("14defb5825819786c86bf25a1a054cdc")
+
+package() {
+ cd $pkgname-$pkgver
+
+ install -Dm755 "scripts/$pkgname.lua" "$pkgdir/usr/lib/mpv/$pkgname.lua"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "README.md" "$pkgdir//usr/share/doc//$pkgname/README.md"
+}
diff --git a/mpv-acestream.install b/mpv-acestream.install
new file mode 100644
index 000000000000..1d48a4ef65b5
--- /dev/null
+++ b/mpv-acestream.install
@@ -0,0 +1,29 @@
+pkgname=mpv-acestream
+
+_post_install_message() {
+ echo
+ echo ">>> To use this script, specify the following option when starting mpv:"
+ echo
+ echo " --script /usr/lib/mpv/$pkgname.lua"
+ echo
+ echo ">>> To use it automatically at every mpv startup:"
+ echo
+ echo " mkdir -p \$HOME/.config/mpv/scripts"
+ echo " ln -s /usr/lib/mpv/$pkgname.lua \$HOME/.config/mpv/scripts/$pkgname.lua"
+echo
+}
+
+_post_uninstall_message() {
+ echo ">>> If you linked $pkgname script into mpv config folder,"
+ echo " do not forget to delete it. Check with:"
+ echo
+ echo " ls \$HOME/.config/mpv/scripts"
+}
+
+post_install() {
+ _post_install_message
+}
+
+post_remove() {
+ _post_uninstall_message
+}