summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-01-31 16:05:24 +0100
committerMarcell Meszaros2024-01-31 16:14:42 +0100
commite2f84f4809265b090c85dc5918693568e4fc72d4 (patch)
tree76abefde0d71f3e55a5fd7b1a38f3db8701b981c
parent564b3a564a679a2de0921b5b09f27aabb784e395 (diff)
downloadaur-e2f84f4809265b090c85dc5918693568e4fc72d4.tar.gz
v0.5 release
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD27
3 files changed, 41 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 661f2acfe93f..1efc8c1e4541 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = mpv-acestream
pkgdesc = Lua script that adds AceStream protocol handler to mpv player
- pkgver = 0.4
+ pkgver = 0.5
pkgrel = 1
url = https://github.com/Digitalone1/mpv-acestream
install = mpv-acestream.install
arch = any
- license = GPL3
- depends = acestream-engine
- depends = mpv
- source = https://github.com/Digitalone1/mpv-acestream/archive/v0.4.tar.gz
+ license = GPL-3.0-or-later
+ source = mpv-acestream-0.5.tar.gz::https://github.com/Digitalone1/mpv-acestream/archive/refs/tags/v0.5.tar.gz
source = acestream.protocol
- md5sums = 8ddf76886cce4ee87615fca71c3828be
- md5sums = b3c9666c4e0aecd92f6fc208a2b3429e
+ b2sums = 492e2aecc38198e33073a0296e4b6b3beaad2800f796b4d2aaa9a2f91bd2f05cf6ed1b7cc2ecbae6addf329fd19c669aaf3b9dda67a0cc4bbfe66fe9246124ed
+ b2sums = 92b697c41f5dec7f0761580e15d3c85c246b1c0de9aa211aa4a0efa3a1988575592411c4695003ff52133b328a7ac7ba11163ec3187bc4f80aeb729476fe15e1
pkgname = mpv-acestream
-
+ depends = acestream-engine-py3
+ depends = mpv
+ optdepends = kio5: acestream protocol support on KDE Plasma 5
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e1cc0116832e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
index 93d1bbc62b36..df2a99d8a86a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,36 @@
-# Maintainer: Giusy Margarita <kurmikon at libero dot it>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Giusy Margarita <kurmikon at libero dot it>
pkgname=mpv-acestream
-pkgver=0.4
+pkgver=0.5
pkgrel=1
pkgdesc="Lua script that adds AceStream protocol handler to mpv player"
arch=("any")
url="https://github.com/Digitalone1/mpv-acestream"
-license=("GPL3")
-depends=(
- "acestream-engine"
- "mpv")
+license=('GPL-3.0-or-later')
source=(
- "https://github.com/Digitalone1/mpv-acestream/archive/v$pkgver.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v$pkgver.tar.gz"
"acestream.protocol")
install="$pkgname.install"
-md5sums=(
- "8ddf76886cce4ee87615fca71c3828be"
- "b3c9666c4e0aecd92f6fc208a2b3429e")
+b2sums=('492e2aecc38198e33073a0296e4b6b3beaad2800f796b4d2aaa9a2f91bd2f05cf6ed1b7cc2ecbae6addf329fd19c669aaf3b9dda67a0cc4bbfe66fe9246124ed'
+ '92b697c41f5dec7f0761580e15d3c85c246b1c0de9aa211aa4a0efa3a1988575592411c4695003ff52133b328a7ac7ba11163ec3187bc4f80aeb729476fe15e1')
package() {
+ depends=(
+ 'acestream-engine-py3'
+ 'mpv'
+ )
+ optdepends=(
+ 'kio5: acestream protocol support on KDE Plasma 5'
+ )
+
cd $pkgname-$pkgver
install -Dm755 "scripts/$pkgname.lua" "$pkgdir/usr/lib/mpv/$pkgname.lua"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
-
+
# Plasma 5 protocol file
install -Dm644 "$srcdir/acestream.protocol" "$pkgdir/usr/share/kservices5/acestream.protocol"
}