summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-10-28 16:26:18 +0200
committersL1pKn072017-10-28 16:26:18 +0200
commit6a38318ee7205ff28ea915c92f28d127abc75b97 (patch)
tree4db4b2873ab0d0d10b3db4538c45d2cded8d379c
parent0f4a31b1d804f4e40628016980295647e4ac83cf (diff)
downloadaur-6a38318ee7205ff28ea915c92f28d127abc75b97.tar.gz
Use ffmpeg-mpv repo instead upstream (now mandatory, see https://github.com/mpv-player/mpv/commit/83d44aca7dc7f46b8d3b64d441f5a8317a40e080)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da28be3efc7a..4601f10f405b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 21 15:11:45 UTC 2017
+# Sat Oct 28 14:25:05 UTC 2017
pkgbase = mpv-build-git
pkgdesc = Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)
- pkgver = v0.27.0.262.g044af63d98
+ pkgver = v0.27.0.308.g3413fe4dfd
pkgrel = 1
url = http://mpv.io
arch = i686
@@ -63,7 +63,7 @@ pkgbase = mpv-build-git
backup = etc/mpv/encoding-profiles.conf
source = git+https://github.com/mpv-player/mpv-build.git
source = git+https://github.com/mpv-player/mpv.git
- source = ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git
+ source = git+https://github.com/mpv-player/ffmpeg-mpv.git
source = git+https://github.com/libass/libass.git
source = https://patch-diff.githubusercontent.com/raw/mpv-player/mpv/pull/4933.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2d5bd6aefb47..2a2bc56fbc3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=mpv-build-git
-pkgver=v0.27.0.262.g044af63d98
+pkgver=v0.27.0.308.g3413fe4dfd
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)"
arch=('i686' 'x86_64' )
@@ -60,7 +60,7 @@ conflicts=('mpv')
options=('!emptydirs')
source=('git+https://github.com/mpv-player/mpv-build.git'
'git+https://github.com/mpv-player/mpv.git'
- 'ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git'
+ 'git+https://github.com/mpv-player/ffmpeg-mpv.git'
'git+https://github.com/libass/libass.git'
'https://patch-diff.githubusercontent.com/raw/mpv-player/mpv/pull/4933.patch'
)
@@ -90,7 +90,7 @@ pkgver() {
prepare() {
cd mpv-build
git clone "${srcdir}/mpv"
- git clone "${srcdir}/ffmpeg"
+ git clone "${srcdir}/ffmpeg-mpv" ffmpeg
git clone "${srcdir}/libass"
# Set ffmpeg/libass/mpv flags
@@ -126,12 +126,10 @@ prepare() {
)
if [ ${_enable_cuda} = "1" ]; then
- _ffmpeg_cuda=(
- '--extra-cflags="-I/opt/cuda/include"'
- )
+ _ffmpeg_options+=('--extra-cflags="-I/opt/cuda/include"')
fi
- echo ${_ffmpeg_options[@]} ${_ffmpeg_cuda[@]} > ffmpeg_options
+ echo ${_ffmpeg_options[@]} > ffmpeg_options
echo ${_mpv_options[@]} > mpv_options
cd mpv