summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-11-13 17:28:27 +0100
committersL1pKn072022-11-13 17:28:27 +0100
commita73aa69357755c46fbffb611babd477f4802bcd5 (patch)
treecc2f785fb6ae820b542cde03b6ffbe05fbdbd29a
parentbbc82c679295cbcca4a6c35a57189ddc660d0e67 (diff)
downloadaur-a73aa69357755c46fbffb611babd477f4802bcd5.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de7ee65af133..4f56a9b11690 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-build-git
pkgdesc = Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)
- pkgver = v0.34.0.519.g42cfed002f
+ pkgver = v0.35.0.2.g1e9a2cbebf
pkgrel = 1
url = http://mpv.io
arch = x86_64
@@ -79,8 +79,6 @@ pkgbase = mpv-build-git
source = git+https://github.com/libass/libass.git
source = git+https://github.com/haasn/libplacebo.git
source = git+https://github.com/Immediate-Mode-UI/Nuklear.git
- source = git+https://github.com/Dav1dde/glad.git
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a636685c65bc..5656f5a87f1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=mpv-build-git
-pkgver=v0.34.0.519.g42cfed002f
+pkgver=v0.35.0.2.g1e9a2cbebf
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)"
arch=('x86_64')
@@ -82,7 +82,6 @@ source=('git+https://github.com/mpv-player/mpv-build.git'
'git+https://github.com/libass/libass.git'
'git+https://github.com/haasn/libplacebo.git'
'git+https://github.com/Immediate-Mode-UI/Nuklear.git'
- 'git+https://github.com/Dav1dde/glad.git'
)
sha256sums=('SKIP'
'SKIP'
@@ -90,7 +89,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
backup=('etc/mpv/encoding-profiles.conf')
@@ -113,14 +111,13 @@ prepare() {
git clone "${srcdir}/libass"
git clone "${srcdir}/libplacebo"
- pushd "${srcdir}/libplacebo"
+ (
+ cd libplacebo
git config submodule.demos/3rdparty/nuklear.url "${srcdir}/Nuklear"
git config submodule.3rdparty/glad.url "${srcdir}/glad"
git -c protocol.file.allow=always submodule update --init \
- demos/3rdparty/nuklear \
- 3rdparty/glad
-
- popd
+ demos/3rdparty/nuklear
+ )
# Set ffmpeg/libass/mpv flags
_ffmpeg_options=(
@@ -178,7 +175,10 @@ fi
'--enable-cuda-interop'
'--color=yes'
)
- _libplacebo_options=('')
+ _libplacebo_options=(
+ '-Dvulkan=enabled'
+ '-Dlcms=enabled'
+ )
(IFS=$'\n'; echo "${_ffmpeg_options[*]}" > ffmpeg_options )
(IFS=$'\n'; echo "${_mpv_options[*]}" > mpv_options )
@@ -191,7 +191,7 @@ fi
build() {
cd mpv-build
- PYTHONPATH="${srcdir}/libplacebo/3rdparty/glad" ./build
+ ./build
}
package() {