summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-04-08 17:10:37 +0200
committersL1pKn072020-04-08 17:10:37 +0200
commitac58abc4ebbe3f559d45cba13144e3f322bc02e6 (patch)
tree45bbcb548e914ba1697bba4465dbc3f80a4cb17d
parent5998aa9927a1c525ed160d1fb9757a38e20acbd1 (diff)
downloadaur-ac58abc4ebbe3f559d45cba13144e3f322bc02e6.tar.gz
bump
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 440390262ca5..b0cdacf33a80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -53,6 +53,7 @@ pkgbase = mpv-build-git
depends = v4l-utils
depends = vulkan-icd-loader
depends = vapoursynth
+ depends = avisynthplus-git
optdepends = nvidia-utils: for hardware accelerated video decoding with CUDA
optdepends = youtube-dl: Another way to view youtuve videos with mpv
optdepends = zsh-completions: Additional completion definitions for Zsh users
diff --git a/PKGBUILD b/PKGBUILD
index f1f5cf571f38..91eb7d088fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,6 +82,9 @@ backup=('etc/mpv/encoding-profiles.conf')
if [ -f /usr/lib/libvapoursynth.so ]; then
depends+=('vapoursynth')
fi
+if [ -f /usr/lib/libavisynth.so.*.*.* ]; then
+ depends+=('avisynthplus-git')
+fi
pkgver() {
cd mpv
@@ -108,8 +111,10 @@ prepare() {
'--enable-libpulse'
'--enable-nonfree'
'--enable-cuda'
- '--enable-avisynth'
)
+if [ -f /usr/lib/libavisynth.so.*.*.* ]; then
+ _ffmpeg_options+=('--enable-avisynth')
+fi
_mpv_options=(
'--prefix=/usr'
'--confdir=/etc/mpv'