summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-07-20 16:51:51 +0200
committersL1pKn072017-07-20 16:51:51 +0200
commitd7c3f81eae2363f64a40e7150e15f450dce2f105 (patch)
treecbf2c869d7eee39811767808c6b7e3f963f0bc0f
parentdab93ba1d48b6b94da801d7811227104101ac01e (diff)
downloadaur-d7c3f81eae2363f64a40e7150e15f450dce2f105.tar.gz
remove SMB support (due license issue) and enable DVB and TV support
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0275405585b9..af984cd2026c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jul 18 21:38:55 UTC 2017
+# Thu Jul 20 14:50:50 UTC 2017
pkgbase = mpv-build-git
pkgdesc = Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)
- pkgver = v0.26.0.1.g9e124933e5
+ pkgver = v0.26.0.3.gf676f6d2b9
pkgrel = 1
url = http://mpv.io
arch = i686
@@ -13,12 +13,12 @@ pkgbase = mpv-build-git
makedepends = git
makedepends = python-docutils
makedepends = yasm
+ makedepends = nasm
makedepends = ladspa
makedepends = fontconfig
makedepends = fribidi
makedepends = cuda
depends = desktop-file-utils
- depends = smbclient
depends = libxv
depends = libcdio-paranoia
depends = openal
@@ -49,6 +49,7 @@ pkgbase = mpv-build-git
depends = libvdpau
depends = fribidi
depends = libmysofa-git
+ depends = mujs
depends = vapoursynth
optdepends = youtube-dl: Another way to view youtuve videos with mpv
optdepends = zsh-completions: Additional completion definitions for Zsh users
diff --git a/PKGBUILD b/PKGBUILD
index 2b9c1e338ae8..eee902106403 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=mpv-build-git
-pkgver=v0.26.0.1.g9e124933e5
+pkgver=v0.26.0.3.gf676f6d2b9
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)"
arch=('i686' 'x86_64' )
depends=('desktop-file-utils'
- 'smbclient'
'libxv'
'libcdio-paranoia'
'openal'
@@ -37,12 +36,14 @@ depends=('desktop-file-utils'
'libvdpau'
'fribidi'
'libmysofa-git'
+ 'mujs'
)
license=('GPL2' 'GPL3' 'LGPL')
url='http://mpv.io'
makedepends=('git'
'python-docutils'
'yasm'
+ 'nasm'
'ladspa'
'fontconfig'
'fribidi'
@@ -103,7 +104,8 @@ prepare() {
'--htmldir=/usr/share/doc/mpv/html'
'--disable-test'
'--disable-build-date'
- '--enable-cplugins'
+ '--disable-vapoursynth-lazy'
+ '--lua=luajit'
'--enable-cdda'
'--enable-dvdnav'
'--enable-dvdread'
@@ -112,10 +114,9 @@ prepare() {
'--enable-sdl2'
'--enable-zsh-comp'
'--enable-libarchive'
- '--lua=luajit'
- '--enable-libavdevice'
- '--disable-vapoursynth-lazy'
'--enable-html-build'
+ '--enable-tv'
+ '--enable-dvbin'
)
if [ ${_enable_cuda} = "1" ]; then