summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-09-01 23:42:21 +0200
committersL1pKn072022-09-01 23:42:21 +0200
commitf95c06225096276ab27d6f0fd9327420a8a9b146 (patch)
treece0fc3dc08a61944744ac72750bdac4268a2218f
parent1331619589e7cfb7edf602fc7b53c190d9941a7c (diff)
downloadaur-f95c06225096276ab27d6f0fd9327420a8a9b146.tar.gz
bump
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce9780fd14dd..6c506febdd19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-build-git
pkgdesc = Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)
- pkgver = v0.34.0.360.g8da6b355f8
+ pkgver = v0.34.0.440.g04062b6f89
pkgrel = 1
url = http://mpv.io
arch = x86_64
@@ -18,6 +18,9 @@ pkgbase = mpv-build-git
makedepends = wayland-protocols
makedepends = ffnvcodec-headers
makedepends = clang
+ makedepends = python-mako
+ makedepends = python-jinja
+ makedepends = python-markupsafe
depends = libfribidi.so
depends = gnutls
depends = libjack.so
@@ -31,7 +34,6 @@ pkgbase = mpv-build-git
depends = libdvdnav
depends = libgme
depends = libmysofa
- depends = libplacebo.so
depends = libpulse.so
depends = libshaderc_shared.so
depends = libsixel
@@ -75,6 +77,12 @@ pkgbase = mpv-build-git
source = git+https://github.com/mpv-player/mpv.git
source = git+https://github.com/ffmpeg/ffmpeg.git
source = git+https://github.com/libass/libass.git
+ source = git+https://github.com/haasn/libplacebo.git
+ source = git+https://github.com/Immediate-Mode-UI/Nuklear.git
+ source = git+https://github.com/Dav1dde/glad.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0d7078ed975c..0d5db56e1c86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=mpv-build-git
-pkgver=v0.34.0.360.g8da6b355f8
+pkgver=v0.34.0.440.g04062b6f89
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)"
arch=('x86_64')
@@ -19,7 +19,6 @@ depends=(
'libdvdnav'
'libgme'
'libmysofa'
- 'libplacebo.so'
'libpulse.so'
'libshaderc_shared.so'
'libsixel'
@@ -60,6 +59,9 @@ makedepends=(
'wayland-protocols'
'ffnvcodec-headers'
'clang'
+ 'python-mako'
+ 'python-jinja'
+ 'python-markupsafe'
)
optdepends=(
'nvidia-utils: for hardware accelerated video decoding with CUDA'
@@ -78,11 +80,17 @@ source=('git+https://github.com/mpv-player/mpv-build.git'
'git+https://github.com/mpv-player/mpv.git'
'git+https://github.com/ffmpeg/ffmpeg.git'
'git+https://github.com/libass/libass.git'
+ 'git+https://github.com/haasn/libplacebo.git'
+ 'git+https://github.com/Immediate-Mode-UI/Nuklear.git'
+ 'git+https://github.com/Dav1dde/glad.git'
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
backup=('etc/mpv/encoding-profiles.conf')
@@ -103,6 +111,16 @@ prepare() {
git clone "${srcdir}/mpv"
git clone "${srcdir}/ffmpeg"
git clone "${srcdir}/libass"
+ git clone "${srcdir}/libplacebo"
+
+ pushd "${srcdir}/libplacebo"
+ git config submodule.demos/3rdparty/nuklear.url "${srcdir}/Nuklear"
+ git config submodule.3rdparty/glad.url "${srcdir}/glad"
+ git submodule update --init \
+ demos/3rdparty/nuklear \
+ 3rdparty/glad
+
+ popd
# Set ffmpeg/libass/mpv flags
_ffmpeg_options=(
@@ -162,9 +180,11 @@ fi
'--enable-cuda-interop'
'--color=yes'
)
+ _libplacebo_options=('')
(IFS=$'\n'; echo "${_ffmpeg_options[*]}" > ffmpeg_options )
(IFS=$'\n'; echo "${_mpv_options[*]}" > mpv_options )
+ (IFS=$'\n'; echo "${_libplacebo_options[*]}" > libplacebo_options )
cd mpv
@@ -173,7 +193,7 @@ fi
build() {
cd mpv-build
- ./build
+ PYTHONPATH="${srcdir}/libplacebo/3rdparty/glad" ./build
}
package() {