summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInochi Amaoto2023-10-28 09:44:03 +0800
committerInochi Amaoto2023-10-28 09:44:03 +0800
commit0c7403c13363d674a0aeccfb8efb35cdd4b5b169 (patch)
tree5b97853aba8b707185bc8b52b885a1ef2673f385
parent26b97d956bf67da46f3b359d7073d32665526a71 (diff)
downloadaur-0c7403c13363d674a0aeccfb8efb35cdd4b5b169.tar.gz
Update: use upstream ffnvcodec header, update options
Signed-off-by: Inochi Amaoto <libraryindexsky@gmail.com>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84a3fcebd3f8..639ca41ed0f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = mpv-full-build-git
pkgdesc = Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )
- pkgver = 0.36.0.r131.g19384e07e4
+ pkgver = 0.36.0.r690.g891efca9d7
pkgrel = 1
url = http://mpv.io
arch = x86_64
license = custom
makedepends = amf-headers
makedepends = avisynthplus
- makedepends = ffnvcodec-headers
makedepends = clang
makedepends = fontconfig
makedepends = git
@@ -171,12 +170,14 @@ pkgbase = mpv-full-build-git
source = ffmpeg::git+https://git.ffmpeg.org/ffmpeg.git
source = libass::git+https://github.com/libass/libass.git
source = libplacebo::git+https://code.videolan.org/videolan/libplacebo.git
+ source = ffnvcodec::git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git
source = LICENSE
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = mpv-full-build-git
diff --git a/PKGBUILD b/PKGBUILD
index 879f5e1b5553..d118bd7af4ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.36.0.r131.g19384e07e4
+pkgver=0.36.0.r690.g891efca9d7
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -127,7 +127,6 @@ url='http://mpv.io'
makedepends=(
'amf-headers'
'avisynthplus'
- 'ffnvcodec-headers'
'clang'
'fontconfig'
'git'
@@ -142,7 +141,7 @@ makedepends=(
'vulkan-headers'
'wayland-protocols'
)
-
+
optdepends=('youtube-dl: Another way to view youtuve videos with mpv'
'zsh-completions: Additional completion definitions for Zsh users')
provides=('mpv' 'mpv-git' 'mpv-build-git' 'mpv-full-git' 'libmpv.so')
@@ -154,6 +153,7 @@ source=('mpv-build::git+https://github.com/mpv-player/mpv-build.git'
'ffmpeg::git+https://git.ffmpeg.org/ffmpeg.git'
'libass::git+https://github.com/libass/libass.git'
'libplacebo::git+https://code.videolan.org/videolan/libplacebo.git'
+ 'ffnvcodec::git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git'
'LICENSE'
)
sha256sums=('SKIP'
@@ -161,6 +161,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36'
)
backup=('etc/mpv/encoding-profiles.conf')
@@ -244,7 +245,17 @@ pkgver() {
# git describe --tags --long | sed 's|^v\(.*\)|\1|;s|\([^-]*-g\)|r\1|;s|-|.|g'
}
+_prepare_ffnvcodec() {
+ make PREFIX=/usr -C "${srcdir}/ffnvcodec"
+ make PREFIX=/usr DESTDIR="${srcdir}" -C "${srcdir}/ffnvcodec" install
+ sed -i "s|=/usr|=${srcdir}/usr|g" "${srcdir}/usr/lib/pkgconfig/ffnvcodec.pc"
+
+ export PKG_CONFIG_PATH=${srcdir}/usr/lib/pkgconfig
+}
+
prepare() {
+ _prepare_ffnvcodec
+
cd mpv-build
ln -sf -t . "../mpv"
ln -sf -t . "../ffmpeg"
@@ -432,7 +443,6 @@ prepare() {
'-Dgl-dxinterop=disabled'
'-Dgl-win32=disabled'
'-Djpeg=enabled'
- '-Dlibplacebo=enabled'
'-Drpi=disabled'
'-Dsdl2-video=enabled'
'-Dshaderc=enabled'