summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInochi Amaoto2023-11-06 09:43:46 +0800
committerInochi Amaoto2023-11-06 09:43:46 +0800
commit2b345750e7822eacce099ab55b089a67d5c41d03 (patch)
tree36aa22c4ba12ca1214906801845ba8996ffb19f7
parent0c7403c13363d674a0aeccfb8efb35cdd4b5b169 (diff)
downloadaur-2b345750e7822eacce099ab55b089a67d5c41d03.tar.gz
Fix: set nvcc g++ to fix ffmpeg cuda detection
Signed-off-by: Inochi Amaoto <libraryindexsky@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 639ca41ed0f5..f6fcdeebfe19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-full-build-git
pkgdesc = Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )
- pkgver = 0.36.0.r690.g891efca9d7
+ pkgver = 0.36.0.r725.g6f8d98f812
pkgrel = 1
url = http://mpv.io
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d118bd7af4ad..33a8795d1e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.36.0.r690.g891efca9d7
+pkgver=0.36.0.r725.g6f8d98f812
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -526,6 +526,7 @@ prepare() {
fi
if [ -d /opt/cuda ]; then
+ export NVCC_PREPEND_FLAGS='-ccbin /opt/cuda/bin/g++'
_ffmpeg_options+=('--enable-cuda-nvcc')
_ffmpeg_options+=('--enable-cuda-llvm')
_ffmpeg_options+=('--enable-libnpp')