summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInochi Amaoto2019-12-16 19:23:30 +0800
committerInochi Amaoto2019-12-16 19:23:30 +0800
commit316a978889fb0cc8755592858be774b6ed56c957 (patch)
treee1b683e871ebce32214405007ea85b3f606f8444
parent2142e82d06e5a2288659bff4c954793353ab1c12 (diff)
downloadaur-316a978889fb0cc8755592858be774b6ed56c957.tar.gz
add libdav1d support(Untested)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b188eefcd2b..29038f131a65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-full-build-git
pkgdesc = Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )
- pkgver = 0.30.0.r102.g8a0929973d
+ pkgver = 0.30.0.r324.gd07b7f068d
pkgrel = 1
url = http://mpv.io
arch = x86_64
@@ -25,7 +25,6 @@ pkgbase = mpv-full-build-git
depends = aribb24
depends = bzip2
depends = celt
- depends = cmocka
depends = dav1d
depends = desktop-file-utils
depends = fontconfig
diff --git a/PKGBUILD b/PKGBUILD
index ea7378877e8b..9b33db337171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.30.0.r102.g8a0929973d
+pkgver=0.30.0.r324.gd07b7f068d
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -12,7 +12,6 @@ depends=(
'aribb24'
'bzip2'
'celt'
- 'cmocka'
'dav1d'
'desktop-file-utils'
'fontconfig'
@@ -266,6 +265,7 @@ prepare() {
'--enable-libcaca'
'--enable-libcdio'
'--enable-libcelt'
+ '--enable-libdav1d'
'--enable-libdc1394'
'--enable-libdrm'
'--enable-libfdk-aac'
@@ -335,7 +335,6 @@ prepare() {
'--prefix=/usr'
'--confdir=/etc/mpv'
'--htmldir=/usr/share/doc/mpv/html'
- '--enable-test'
'--disable-build-date'
'--lua=luajit'
'--enable-alsa'
@@ -393,19 +392,21 @@ prepare() {
'--enable-zlib'
)
- # '--enable-vaapi-glx'
+ # ffmpeg: removed or can't build
# '--disable-vapoursynth-lazy'
- # '--enable-omx-rpi'
- # '--enable-libdav1d'
+ # [N] '--enable-omx-rpi'
# '--enable-libsmbclient'
- # '--enable-avresample'
+ # [D] '--enable-avresample'
- # '--enable-zsh-comp'
- # '--enable-audio-input'
- # '--enable-dvdread'
- # '--enable-libv4l2'
- # '--enable-tv'
- # '--enable-tv-v4l2'
+ # mpv: removed or can't build
+ # [R] '--enable-zsh-comp'
+ # [R] '--enable-audio-input'
+ # [R] '--enable-dvdread'
+ # [R] '--enable-libv4l2'
+ # [R] '--enable-tv'
+ # [R] '--enable-tv-v4l2'
+ # [R] '--enable-vaapi-glx'
+ # [O] '--enable-test'
local _ffmpeg_cflags=''