summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInochi Amaoto2020-01-11 13:37:13 +0800
committerInochi Amaoto2020-01-11 13:37:13 +0800
commit85fc64da762bdbc66faff3a2c42de4ed4204b859 (patch)
treef442aaa95c849a5415c79a1f400f51caeb6d3151
parent316a978889fb0cc8755592858be774b6ed56c957 (diff)
downloadaur-85fc64da762bdbc66faff3a2c42de4ed4204b859.tar.gz
fix options
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29038f131a65..4f342c3da4b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-full-build-git
pkgdesc = Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )
- pkgver = 0.30.0.r324.gd07b7f068d
+ pkgver = 0.31.0.r57.g8b85b40b2f
pkgrel = 1
url = http://mpv.io
arch = x86_64
@@ -25,6 +25,7 @@ pkgbase = mpv-full-build-git
depends = aribb24
depends = bzip2
depends = celt
+ depends = codec2
depends = dav1d
depends = desktop-file-utils
depends = fontconfig
@@ -119,7 +120,6 @@ pkgbase = mpv-full-build-git
depends = zlib
depends = zvbi
depends = chromaprint-fftw
- optdepends = codec2: Additional libcodec2 support for ffmpeg
optdepends = cuda: mpv ffmpeg nvcc and libnpp support
optdepends = davs2: Additional libdavs2 support for ffmpeg
optdepends = flite1-patched: Additional libflite support for ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 9b33db337171..3c88794458e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.30.0.r324.gd07b7f068d
+pkgver=0.31.0.r57.g8b85b40b2f
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -12,6 +12,7 @@ depends=(
'aribb24'
'bzip2'
'celt'
+ 'codec2'
'dav1d'
'desktop-file-utils'
'fontconfig'
@@ -124,7 +125,6 @@ makedepends=(
'ffnvcodec-headers'
)
optdepends=(
- 'codec2: Additional libcodec2 support for ffmpeg'
'cuda: mpv ffmpeg nvcc and libnpp support'
'davs2: Additional libdavs2 support for ffmpeg'
'flite1-patched: Additional libflite support for ffmpeg'
@@ -170,9 +170,6 @@ backup=('etc/mpv/encoding-profiles.conf')
# MPV_NO_CHECK_OPT_DEPEND=yes makepkg -sif
if [ -z ${MPV_NO_CHECK_OPT_DEPEND+yes} ]; then
- if [ -f /usr/lib/libcodec2.so ]; then
- depends+=('codec2')
- fi
if [ -f /usr/lib/libdavs2.so ]; then
depends+=('davs2')
fi
@@ -265,6 +262,7 @@ prepare() {
'--enable-libcaca'
'--enable-libcdio'
'--enable-libcelt'
+ '--enable-libcodec2'
'--enable-libdav1d'
'--enable-libdc1394'
'--enable-libdrm'
@@ -412,9 +410,6 @@ prepare() {
local _ffmpeg_cflags=''
local _ffmpeg_ldflags=''
if [ -z ${MPV_NO_CHECK_OPT_DEPEND+yes} ]; then
- if [ -f /usr/lib/libcodec2.so ]; then
- _ffmpeg_options+=('--enable-libcodec2')
- fi
if [ -f /usr/lib/libdavs2.so ]; then
_ffmpeg_options+=('--enable-libdavs2')
fi
@@ -471,6 +466,7 @@ prepare() {
_ffmpeg_options+=('--extra-cflags=-I/opt/cuda/include')
_ffmpeg_options+=('--extra-ldflags=-L/opt/cuda/lib64')
_mpv_options+=('--enable-cuda-hwaccel')
+ _mpv_options+=('--enable-cuda-interop')
fi
fi