summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInochi Amaoto2023-12-02 12:40:38 +0800
committerInochi Amaoto2023-12-02 12:40:38 +0800
commit965f54cffe254fc205c8ad59a2690211bc5ddbc1 (patch)
tree06b61c66b3a54da72589e1a6f2d2780bd4947057
parent101c7e25b3c488ba97751a17bf39d01695818e10 (diff)
downloadaur-965f54cffe254fc205c8ad59a2690211bc5ddbc1.tar.gz
Update: Fix some errors
1. remove spirv-cross for mpv build 2. reenable tensorflow 3. allow to build ffmpeg against glslang git Signed-off-by: Inochi Amaoto <libraryindexsky@gmail.com>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a2401e881b6..b5a416e04186 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-full-build-git
pkgdesc = Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )
- pkgver = 0.37.0.r9.ge22a2f0483
+ pkgver = 0.37.0.r56.g67aa568437
pkgrel = 1
url = http://mpv.io
arch = x86_64
@@ -97,6 +97,7 @@ pkgbase = mpv-full-build-git
depends = ocl-icd
depends = openal
depends = opencore-amr
+ depends = openh264
depends = openjpeg2
depends = openmp
depends = opus
@@ -140,9 +141,7 @@ pkgbase = mpv-full-build-git
optdepends = libsixel: Allow mpv to implement sixel as a output device
optdepends = nvidia-utils: for hardware accelerated video decoding with CUDA
optdepends = onevpl: mpv ffmpeg intel graphic support
- optdepends = openh264: Additional libopenh264 support for ffmpeg
optdepends = shine: Additional libshine support for ffmpeg
- optdepends = spirv-cross: Additional spirv support for mpv
optdepends = tensorflow: mpv ffmpeg DNN module backend
optdepends = vo-amrwbenc: Additional libvo-amrwbenc support for ffmpeg
optdepends = xavs: Additional libxavs support for ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 7c82a237dada..37fe8a783816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.37.0.r9.ge22a2f0483
+pkgver=0.37.0.r56.g67aa568437
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -85,6 +85,7 @@ depends=(
'ocl-icd'
'openal'
'opencore-amr'
+ 'openh264'
'openjpeg2'
'openmp'
'opus'
@@ -178,9 +179,7 @@ _makeoptdepends=('cuda: mpv ffmpeg nvcc and libnpp support'
'libsixel: Allow mpv to implement sixel as a output device'
'nvidia-utils: for hardware accelerated video decoding with CUDA'
'onevpl: mpv ffmpeg intel graphic support'
- 'openh264: Additional libopenh264 support for ffmpeg'
'shine: Additional libshine support for ffmpeg'
- 'spirv-cross: Additional spirv support for mpv'
'tensorflow: mpv ffmpeg DNN module backend'
'vo-amrwbenc: Additional libvo-amrwbenc support for ffmpeg'
'xavs: Additional libxavs support for ffmpeg'
@@ -197,12 +196,6 @@ if [ -z ${MPV_NO_CHECK_OPT_DEPEND+yes} ]; then
if [ -f /usr/lib/libklvanc.so ]; then
depends+=('libklvanc')
fi
- if [ -f /usr/lib/libopenh264.so ]; then
- depends+=('openh264')
- fi
- if [ -f /usr/lib/libspirv-cross-c-shared.so ]; then
- depends+=('spirv-cross')
- fi
if [ -f /usr/lib/libshine.so ]; then
depends+=('shine')
fi
@@ -312,6 +305,7 @@ prepare() {
'--enable-libmysofa'
'--enable-libopencore-amrnb'
'--enable-libopencore-amrwb'
+ '--enable-libopenh264'
'--enable-libopenjpeg'
'--enable-libopenmpt'
'--enable-libopus'
@@ -445,7 +439,7 @@ prepare() {
'-Djpeg=enabled'
'-Drpi=disabled'
'-Dsdl2-video=enabled'
- '-Dshaderc=enabled'
+ '-Dshaderc=disabled'
'-Dplain-gl=enabled'
'-Dvdpau=enabled'
'-Dvaapi=enabled'
@@ -488,6 +482,10 @@ prepare() {
'-Dd3d11=disabled'
)
+ if [ ! -f /usr/lib/libHLSL.so ]; then
+ sed -i 's|-lHLSL||g' ffmpeg/configure;
+ sed -i 's|-lOGLCompiler||g' ffmpeg/configure;
+ fi
if [ -z ${MPV_NO_CHECK_OPT_DEPEND+yes} ]; then
if [ -f /usr/lib/libdavs2.so ]; then
@@ -496,12 +494,6 @@ prepare() {
if [ -f /usr/lib/libklvanc.so ]; then
_ffmpeg_options+=('--enable-libklvanc')
fi
- if [ -f /usr/lib/libopenh264.so ]; then
- _ffmpeg_options+=('--enable-libopenh264')
- fi
- if [ -f /usr/lib/libspirv-cross-c-shared.so ]; then
- _mpv_options+=('-Dspirv-cross=enabled')
- fi
if [ -f /usr/lib/libshine.so ]; then
_ffmpeg_options+=('--enable-libshine')
fi
@@ -514,7 +506,7 @@ prepare() {
_ffmpeg_options+=('--enable-libmfx')
fi
if [ -f /usr/lib/libtensorflow.so ]; then
- #_ffmpeg_options+=('--enable-libtensorflow')
+ _ffmpeg_options+=('--enable-libtensorflow')
_ffmpeg_options+=('--extra-cflags=-I/usr/include/tensorflow')
fi
if [ -f /usr/lib/libvo-amrwbenc.so ]; then