summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-10-27 16:11:32 -0200
committerDaniel Bermond2017-10-27 16:11:32 -0200
commit208c5355653a0eaa6e243302bd380ae61241d170 (patch)
tree54eb92fa9e57d0882e7a0ce913faaa2c0ee14e15
parent82ab20f3e99c17cf55ebf641e49ac9ad47ea0de4 (diff)
downloadaur-208c5355653a0eaa6e243302bd380ae61241d170.tar.gz
Allow build with upstream ffmpeg (not officially supported anymore)
mpv has removed official support for upstream ffmpeg. Now mpv requires the git master branch of its own modified version of ffmpeg, called ffmpeg-mpv. Note the git master requirement, as the stable releases of ffmpeg-mpv currently seems not to contain any mpv modifications. I have introduced a patch to allow build with upstream ffmpeg, but be warned that this is not the mpv upstream recommendation. If you want the most clean mpv experience as possible you should use the package ffmpeg-mpv-git (or any other similar variant) to build and use mpv. References ---------- https://github.com/mpv-player/mpv/commit/83d44aca7dc7f46b8d3b64d441f5a8317a40e080 https://github.com/mpv-player/ffmpeg-mpv/
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--mpv-allow-upstream-ffmpeg.patch42
3 files changed, 56 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9259a749dffd..40bf06fa411d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 24 19:22:11 UTC 2017
+# Fri Oct 27 18:02:56 UTC 2017
pkgbase = mpv-full-git
pkgdesc = A free, open source, and cross-platform media player (git version with all possible libs)
- pkgver = 0.27.0.r282.ga5b51f75dc
+ pkgver = 0.27.0.r308.g3413fe4dfd
pkgrel = 1
url = http://mpv.io/
arch = i686
@@ -51,7 +51,9 @@ pkgbase = mpv-full-git
conflicts = mpv-git
options = !emptydirs
source = mpv-full-git::git+https://github.com/mpv-player/mpv.git
+ source = mpv-allow-upstream-ffmpeg.patch
sha256sums = SKIP
+ sha256sums = 3bb1a954d58c914682a2a8564434de61e52fe9467c85ee38123ea7d61b7a40fd
pkgname = mpv-full-git
diff --git a/PKGBUILD b/PKGBUILD
index 34f5602d29a0..27e9b65ade75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=mpv-full-git
-pkgver=0.27.0.r282.ga5b51f75dc
+pkgver=0.27.0.r308.g3413fe4dfd
pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (git version with all possible libs)'
arch=('i686' 'x86_64')
@@ -25,8 +25,15 @@ makedepends=('git' 'mesa' 'python-docutils' 'ladspa' 'vulkan-headers'
provides=('mpv')
conflicts=('mpv' 'mpv-git')
options=('!emptydirs')
-source=("$pkgname"::'git+https://github.com/mpv-player/mpv.git')
-sha256sums=('SKIP')
+source=("$pkgname"::'git+https://github.com/mpv-player/mpv.git'
+ 'mpv-allow-upstream-ffmpeg.patch')
+sha256sums=('SKIP'
+ '3bb1a954d58c914682a2a8564434de61e52fe9467c85ee38123ea7d61b7a40fd')
+
+prepare() {
+ cd "$pkgname"
+ patch -Np1 -i "${srcdir}/mpv-allow-upstream-ffmpeg.patch"
+}
pkgver() {
cd "$pkgname"
diff --git a/mpv-allow-upstream-ffmpeg.patch b/mpv-allow-upstream-ffmpeg.patch
new file mode 100644
index 000000000000..16a4635e2a52
--- /dev/null
+++ b/mpv-allow-upstream-ffmpeg.patch
@@ -0,0 +1,42 @@
+commit 877ffb81f359866286e2c2d5ce268b8f3dd6dd41
+Author: Daniel Bermond <danielbermond@yahoo.com>
+Date: Fri Oct 27 15:45:28 2017 -0200
+
+ Allow build with upstream ffmpeg
+
+diff --git a/wscript b/wscript
+index e25a7667ad..f015b11eee 100644
+--- a/wscript
++++ b/wscript
+@@ -462,18 +462,12 @@ libav_dependencies = [
+ 'req': True,
+ 'fmsg': "FFmpeg/Libav development files not found.",
+ }, {
+- 'name': 'is_ffmpeg_garbage',
+- 'desc': 'libav* is upstream FFmpeg (unsupported)',
++ 'name': 'is_ffmpeg',
++ 'desc': 'libav* is FFmpeg',
+ # FFmpeg <=> LIBAVUTIL_VERSION_MICRO>=100
+ 'func': check_statement('libavcodec/version.h',
+ 'int x[LIBAVCODEC_VERSION_MICRO >= 100 ? 1 : -1]',
+ use='libavcodec')
+- }, {
+- 'name': 'is_ffmpeg',
+- 'desc': 'libav* is FFmpeg mpv modified version',
+- 'func': check_statement('libavcodec/version.h',
+- 'int x[LIBAVCODEC_MPV ? 1 : -1]',
+- use='libavcodec')
+ }, {
+ # This check should always result in the opposite of is_ffmpeg.
+ # Run it to make sure is_ffmpeg didn't fail for some other reason than
+@@ -491,9 +485,7 @@ libav_dependencies = [
+ 'func': check_ffmpeg_or_libav_versions(),
+ 'req': True,
+ 'fmsg': "Unable to find development files for some of the required \
+-FFmpeg/Libav libraries. You need at least {0}. For FFmpeg, the mpv fork, that \
+-might contain additional fixes and features is required. It is available on \
+-https://github.com/mpv-player/ffmpeg-mpv Aborting.".format(libav_versions_string)
++FFmpeg/Libav libraries. You need at least {0}. Aborting.".format(libav_versions_string)
+ }, {
+ 'name': '--libavdevice',
+ 'desc': 'libavdevice',