summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-01-16 14:27:49 -0200
committerDaniel Bermond2018-01-16 14:27:49 -0200
commit2f20505164f468c705a02ecf3227d5a436753b42 (patch)
treeafc14d226f985236ceb28e84deff7b141666aadd
parentc7cc328d0986371696574ae7d512568419d9daf4 (diff)
downloadaur-2f20505164f468c705a02ecf3227d5a436753b42.tar.gz
depends: switch ffmpeg to ffmpeg-git
This seems to make sense since mpv currently requires ffmpeg git master. So, ffmpeg-git from the AUR (or some variant) is needed. This also implies switching vapoursynth to vapoursynth-git.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 415ac35dca36..29bc132dcae8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Dec 5 14:07:07 UTC 2017
pkgbase = mpv-full-git
pkgdesc = A free, open source, and cross-platform media player (git version with all possible libs)
- pkgver = 0.27.0.r493.gf19797dea6
+ pkgver = 0.28.0.r121.g0192eeb09c
pkgrel = 1
url = http://mpv.io/
arch = i686
@@ -14,7 +12,6 @@ pkgbase = mpv-full-git
makedepends = ladspa
makedepends = vulkan-headers
makedepends = wayland-protocols
- depends = ffmpeg
depends = lcms2
depends = libcdio-paranoia
depends = libgl
@@ -37,14 +34,15 @@ pkgbase = mpv-full-git
depends = libarchive
depends = openal
depends = smbclient
- depends = vapoursynth
depends = vulkan-icd-loader
depends = zlib
+ depends = ffmpeg-git
depends = mujs
depends = rsound
depends = sndio
depends = shaderc-git
depends = crossc
+ depends = vapoursynth-git
optdepends = youtube-dl: for video-sharing websites playback
optdepends = nvidia-utils: for hardware accelerated video decoding with CUDA
provides = mpv
diff --git a/PKGBUILD b/PKGBUILD
index 1bdde0746b41..44aff3b527fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=mpv-full-git
-pkgver=0.27.0.r493.gf19797dea6
+pkgver=0.28.0.r121.g0192eeb09c
pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (git version with all possible libs)'
arch=('i686' 'x86_64')
@@ -9,14 +9,15 @@ license=('GPL3')
url='http://mpv.io/'
depends=(
# official repositories:
- 'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
+ 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'wayland' 'libcaca'
'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive'
- 'openal' 'smbclient' 'vapoursynth' 'vulkan-icd-loader' 'zlib'
+ 'openal' 'smbclient' 'vulkan-icd-loader' 'zlib'
# AUR:
- 'mujs' 'rsound' 'sndio' 'shaderc-git' 'crossc'
+ 'ffmpeg-git' 'mujs' 'rsound' 'sndio' 'shaderc-git' 'crossc'
+ 'vapoursynth-git'
)
optdepends=('youtube-dl: for video-sharing websites playback'
'nvidia-utils: for hardware accelerated video decoding with CUDA')
@@ -133,6 +134,7 @@ build() {
--disable-direct3d \
--enable-shaderc \
--enable-crossc \
+ --disable-d3d11 \
--disable-rpi \
--disable-ios-gl \
--enable-plain-gl \