summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-11-01 16:52:23 -0200
committerDaniel Bermond2017-11-01 16:52:23 -0200
commit4263266a1c06eb084e70d63fda8c18667f5fa9b9 (patch)
treebdb924aa39988d882a2eb9a9ed359ed36184b5a7
parent208c5355653a0eaa6e243302bd380ae61241d170 (diff)
downloadaur-4263266a1c06eb084e70d63fda8c18667f5fa9b9.tar.gz
Fix build (currently it only compiles with ffmpeg-mpv-git)
Upstream mpv currently only compiles with ffmpeg-mpv-git. There is a new option --enable-ffmpeg-upstream, but paradoxically it currently does not work with upstream ffmpeg git master (https://github.com/mpv-player/mpv/issues/5066).
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--mpv-allow-upstream-ffmpeg.patch42
-rw-r--r--mpv-fix-cuda-detection.patch12
4 files changed, 27 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40bf06fa411d..35abda8f8c19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Oct 27 18:02:56 UTC 2017
+# Wed Nov 1 18:51:54 UTC 2017
pkgbase = mpv-full-git
pkgdesc = A free, open source, and cross-platform media player (git version with all possible libs)
- pkgver = 0.27.0.r308.g3413fe4dfd
+ pkgver = 0.27.0.r331.g27ab99dc3e
pkgrel = 1
url = http://mpv.io/
arch = i686
@@ -14,7 +14,7 @@ pkgbase = mpv-full-git
makedepends = ladspa
makedepends = vulkan-headers
makedepends = wayland-protocols
- depends = ffmpeg
+ depends = ffmpeg-mpv-git
depends = lcms2
depends = libcdio-paranoia
depends = libgl
@@ -51,9 +51,9 @@ pkgbase = mpv-full-git
conflicts = mpv-git
options = !emptydirs
source = mpv-full-git::git+https://github.com/mpv-player/mpv.git
- source = mpv-allow-upstream-ffmpeg.patch
+ source = mpv-fix-cuda-detection.patch
sha256sums = SKIP
- sha256sums = 3bb1a954d58c914682a2a8564434de61e52fe9467c85ee38123ea7d61b7a40fd
+ sha256sums = d73dc3ee054d2552cc9c091106f60e3fba779d3708f21ceee7fad18805a890e6
pkgname = mpv-full-git
diff --git a/PKGBUILD b/PKGBUILD
index 27e9b65ade75..722c5e421369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=mpv-full-git
-pkgver=0.27.0.r308.g3413fe4dfd
+pkgver=0.27.0.r331.g27ab99dc3e
pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (git version with all possible libs)'
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ license=('GPL3')
url='http://mpv.io/'
depends=(
# official repositories:
- 'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
+ 'ffmpeg-mpv-git' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'wayland' 'libcaca'
'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive'
@@ -26,13 +26,13 @@ provides=('mpv')
conflicts=('mpv' 'mpv-git')
options=('!emptydirs')
source=("$pkgname"::'git+https://github.com/mpv-player/mpv.git'
- 'mpv-allow-upstream-ffmpeg.patch')
+ 'mpv-fix-cuda-detection.patch')
sha256sums=('SKIP'
- '3bb1a954d58c914682a2a8564434de61e52fe9467c85ee38123ea7d61b7a40fd')
+ 'd73dc3ee054d2552cc9c091106f60e3fba779d3708f21ceee7fad18805a890e6')
prepare() {
cd "$pkgname"
- patch -Np1 -i "${srcdir}/mpv-allow-upstream-ffmpeg.patch"
+ patch -Np1 -i "${srcdir}/mpv-fix-cuda-detection.patch"
}
pkgver() {
@@ -50,6 +50,10 @@ build() {
msg2 'Running bootstrap. Please wait...'
./bootstrap.py
+ CFLAGS='-I/usr/include/ffmpeg-mpv-git' \
+ LDFLAGS='-L/usr/lib/ffmpeg-mpv-git' \
+ PKG_CONFIG_PATH='/usr/lib/ffmpeg-mpv-git/pkgconfig' \
+ \
./waf configure \
--color='yes' \
--prefix='/usr' \
@@ -93,6 +97,7 @@ build() {
--enable-vapoursynth \
--enable-vapoursynth-lazy \
--enable-libarchive \
+ --disable-ffmpeg-upstream \
--enable-libavdevice \
--lua='52arch' \
\
@@ -148,9 +153,7 @@ build() {
--enable-vulkan \
--enable-shaderc \
\
- --enable-vaapi-hwaccel \
--disable-videotoolbox-gl \
- --enable-vdpau-hwaccel \
--disable-d3d-hwaccel \
--disable-d3d9-hwaccel \
--disable-gl-dxinterop-d3d9 \
diff --git a/mpv-allow-upstream-ffmpeg.patch b/mpv-allow-upstream-ffmpeg.patch
deleted file mode 100644
index 16a4635e2a52..000000000000
--- a/mpv-allow-upstream-ffmpeg.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-commit 877ffb81f359866286e2c2d5ce268b8f3dd6dd41
-Author: Daniel Bermond <danielbermond@yahoo.com>
-Date: Fri Oct 27 15:45:28 2017 -0200
-
- Allow build with upstream ffmpeg
-
-diff --git a/wscript b/wscript
-index e25a7667ad..f015b11eee 100644
---- a/wscript
-+++ b/wscript
-@@ -462,18 +462,12 @@ libav_dependencies = [
- 'req': True,
- 'fmsg': "FFmpeg/Libav development files not found.",
- }, {
-- 'name': 'is_ffmpeg_garbage',
-- 'desc': 'libav* is upstream FFmpeg (unsupported)',
-+ 'name': 'is_ffmpeg',
-+ 'desc': 'libav* is FFmpeg',
- # FFmpeg <=> LIBAVUTIL_VERSION_MICRO>=100
- 'func': check_statement('libavcodec/version.h',
- 'int x[LIBAVCODEC_VERSION_MICRO >= 100 ? 1 : -1]',
- use='libavcodec')
-- }, {
-- 'name': 'is_ffmpeg',
-- 'desc': 'libav* is FFmpeg mpv modified version',
-- 'func': check_statement('libavcodec/version.h',
-- 'int x[LIBAVCODEC_MPV ? 1 : -1]',
-- use='libavcodec')
- }, {
- # This check should always result in the opposite of is_ffmpeg.
- # Run it to make sure is_ffmpeg didn't fail for some other reason than
-@@ -491,9 +485,7 @@ libav_dependencies = [
- 'func': check_ffmpeg_or_libav_versions(),
- 'req': True,
- 'fmsg': "Unable to find development files for some of the required \
--FFmpeg/Libav libraries. You need at least {0}. For FFmpeg, the mpv fork, that \
--might contain additional fixes and features is required. It is available on \
--https://github.com/mpv-player/ffmpeg-mpv Aborting.".format(libav_versions_string)
-+FFmpeg/Libav libraries. You need at least {0}. Aborting.".format(libav_versions_string)
- }, {
- 'name': '--libavdevice',
- 'desc': 'libavdevice',
diff --git a/mpv-fix-cuda-detection.patch b/mpv-fix-cuda-detection.patch
new file mode 100644
index 000000000000..b0c47e853a00
--- /dev/null
+++ b/mpv-fix-cuda-detection.patch
@@ -0,0 +1,12 @@
+diff -Narup a/wscript b/wscript
+--- a/wscript 2017-11-01 14:39:24.000000000 -0200
++++ b/wscript 2017-11-01 15:11:49.308363399 -0200
+@@ -852,7 +852,7 @@ hwaccel_features = [
+ 'desc': 'CUDA hwaccel',
+ 'deps': 'gl',
+ 'func': check_cc(fragment=load_fragment('cuda.c'),
+- use='libav'),
++ use=['libav', 'libavcodec']),
+ }
+ ]
+