summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-10 01:48:59 +0000
committerDaniel Bermond2018-11-10 01:48:59 +0000
commit7f77d1933d53343be2366bf8073ab991209f95c3 (patch)
tree64ec4331103db0cfc77cbe3aade6ffc1eeef2c08
parent6239184fb83f716844401c48c4e4c5472ba6e336 (diff)
downloadaur-7f77d1933d53343be2366bf8073ab991209f95c3.tar.gz
Do not rename source clone. Use https for url.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f73105b5e0a..cf275992f91e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mpv-full-git
pkgdesc = A free, open source, and cross-platform media player (git version with all possible libs)
- pkgver = 0.29.1.r77.gba2dee38fb
+ pkgver = 0.29.1.r88.g317d3ac266
pkgrel = 1
- url = http://mpv.io/
+ url = https://mpv.io/
arch = i686
arch = x86_64
license = GPL3
@@ -50,7 +50,7 @@ pkgbase = mpv-full-git
provides = mpv-git
conflicts = mpv
options = !emptydirs
- source = mpv-full-git::git+https://github.com/mpv-player/mpv.git
+ source = git+https://github.com/mpv-player/mpv.git
sha256sums = SKIP
pkgname = mpv-full-git
diff --git a/PKGBUILD b/PKGBUILD
index fbe165b261a7..703a023d727f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=mpv-full-git
-pkgver=0.29.1.r77.gba2dee38fb
+_srcname=mpv
+pkgver=0.29.1.r88.g317d3ac266
pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (git version with all possible libs)'
arch=('i686' 'x86_64')
license=('GPL3')
-url='http://mpv.io/'
+url='https://mpv.io/'
depends=(
# official repositories:
'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
@@ -25,11 +26,11 @@ optdepends=('youtube-dl: for video-sharing websites playback'
provides=('mpv' 'mpv-git')
conflicts=('mpv')
options=('!emptydirs')
-source=("$pkgname"::'git+https://github.com/mpv-player/mpv.git')
+source=('git+https://github.com/mpv-player/mpv.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
local _version
local _revision
@@ -43,7 +44,7 @@ pkgver() {
}
build() {
- cd "$pkgname"
+ cd "$_srcname"
./bootstrap.py
@@ -165,7 +166,7 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "$_srcname"
./waf install --destdir="$pkgdir"