summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-09-14 00:24:16 +0000
committerDaniel Bermond2019-09-14 00:25:47 +0000
commit85105aad8afb8416b1ddd246d51ee68835bff17d (patch)
tree4fddfc5d0a1fdd32a79aec8c98c6db01626ba992
parent110c431b4292192eb7583c4722a9f790412ffd91 (diff)
downloadaur-85105aad8afb8416b1ddd246d51ee68835bff17d.tar.gz
Remove dropped options (dvdread, tv and audio-input). Add tests.
Upstream dropped some options. References ---------- https://github.com/mpv-player/mpv/commit/62294049852549e99ec948e0df16452856afa0c1 https://github.com/mpv-player/mpv/commit/ebab42c9a826e346faa89482847f442546a554f5 https://github.com/mpv-player/mpv/commit/b30e85508a305d668db8419556d295a65ab08707
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f550620a29f..f9c5c5fe041d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-full-git
pkgdesc = A free, open source, and cross-platform media player (git version with all possible libs)
- pkgver = 0.29.1.r338.g6aecd10eba
+ pkgver = 0.29.1.r400.gebab42c9a8
pkgrel = 1
url = https://mpv.io/
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = mpv-full-git
makedepends = vulkan-headers
makedepends = wayland-protocols
makedepends = ffnvcodec-headers
+ depends = cmocka
depends = ffmpeg
depends = lcms2
depends = libcdio-paranoia
diff --git a/PKGBUILD b/PKGBUILD
index e9663cc756ba..e9a290826941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=mpv-full-git
-pkgver=0.29.1.r338.g6aecd10eba
+pkgver=0.29.1.r400.gebab42c9a8
pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (git version with all possible libs)'
arch=('x86_64')
@@ -9,7 +9,7 @@ license=('GPL3')
url='https://mpv.io/'
depends=(
# official repositories:
- 'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
+ 'cmocka' 'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'wayland' 'libcaca'
'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive' 'smbclient'
@@ -69,7 +69,7 @@ build() {
\
--enable-cplugins \
--enable-zsh-comp \
- --disable-test \
+ --enable-test \
--disable-clang-database \
\
--disable-android \
@@ -85,7 +85,6 @@ build() {
--enable-libass-osd \
--enable-zlib \
--enable-libbluray \
- --enable-dvdread \
--enable-dvdnav \
--enable-cdda \
--enable-uchardet \
@@ -94,6 +93,7 @@ build() {
--enable-vapoursynth \
--enable-vapoursynth-lazy \
--enable-libarchive \
+ --enable-dvbin \
--enable-libavdevice \
--lua='52arch' \
\
@@ -157,19 +157,26 @@ build() {
--disable-gl-dxinterop-d3d9 \
--enable-cuda-hwaccel \
\
- --enable-tv \
- --enable-tv-v4l2 \
- --enable-libv4l2 \
- --enable-audio-input \
- --enable-dvbin \
- \
--disable-apple-remote \
--disable-macos-touchbar \
+ --disable-macos-10-11-features \
+ --disable-macos-10-14-features \
--disable-macos-cocoa-cb
./waf build
}
+check() {
+ cd mpv/build/test
+
+ local _test
+ while read -r -d '' _test
+ do
+ printf '%s\n' " -> Running test '${_test##*/}'..."
+ "$_test"
+ done < <(find . -executable -type f -print0)
+}
+
package() {
cd mpv