summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2019-10-02 21:40:53 -0400
committerPhilip Sequeira2019-10-02 21:40:53 -0400
commit262f93ac449c0cf04e9873821131c4ed9f29e90d (patch)
tree77cb8f8e5dc1992e9dd854c4e761afa3a29c689c
parent31429e4c9dd0007b4b5b80a3c0367fdb664187a1 (diff)
downloadaur-262f93ac449c0cf04e9873821131c4ed9f29e90d.tar.gz
make vulkan support default (it effectively already was)
ffmpeg transitively depends on libplacebo and vulkan-icd-loader. We still need to add vulkan-headers for to build with vulkan support, but there's no longer any reason not to enable it by default.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 5 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4e7cb652933..cedece7bc8d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Sep 27 22:06:20 UTC 2019
+# Thu Oct 3 01:39:01 UTC 2019
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.29.0_747_gc7d0a8f58e
+ pkgver = 0.29.0_802_gdefc8f359c
pkgrel = 1
url = https://mpv.io
install = mpv.install
@@ -14,6 +14,7 @@ pkgbase = mpv-git
makedepends = git
makedepends = python-docutils
makedepends = pacman-contrib
+ makedepends = vulkan-headers
depends = ffmpeg
depends = hicolor-icon-theme
optdepends = youtube-dl: for --ytdl
diff --git a/PKGBUILD b/PKGBUILD
index 45f4c36b4cd4..39bc148f08fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,6 @@ _opt_features=(
#x11
#wayland
- #vulkan
#shaderc # preferred SPIR-V compiler; available from AUR
#uchardet
@@ -48,7 +47,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.29.0_747_gc7d0a8f58e
+pkgver=0.29.0_802_gdefc8f359c
pkgrel=1
_waf_version=2.0.9
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
@@ -58,7 +57,7 @@ url='https://mpv.io'
_undetected_depends=('hicolor-icon-theme')
depends=('ffmpeg' "${_undetected_depends[@]}")
optdepends=('youtube-dl: for --ytdl')
-makedepends=('git' 'python-docutils' 'pacman-contrib')
+makedepends=('git' 'python-docutils' 'pacman-contrib' 'vulkan-headers')
provides=('mpv')
conflicts=('mpv')
options=('!emptydirs')
@@ -70,17 +69,6 @@ sha256sums=('SKIP'
'1ba780ede4a28b68ae5b7ab839958ff91ed01d3c6c1d24cce8a5dd24492f8d2b'
'2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48')
-# vulkan-icd-loader contains vulkan.pc, which makes mpv think it can build
-# against Vulkan. However, the headers required to actually do so are in another
-# package, vulkan-headers, for whatever reason. Building with only the former
-# installed will fail. So if we see the .pc installed, make sure the headers are
-# too.
-#
-# See also: https://bugs.archlinux.org/task/56238
-if pkg-config --exists vulkan; then
- makedepends+=('vulkan-headers')
-fi
-
_opt_extra_flags=()
for feature in "${_opt_features[@]}"; do
@@ -115,10 +103,6 @@ for feature in "${_opt_features[@]}"; do
wayland)
depends+=('wayland' 'libxkbcommon')
;;
- vulkan)
- makedepends+=('vulkan-headers')
- depends+=('libplacebo')
- ;;
shaderc|uchardet|rubberband)
depends+=("$feature")
;;