summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2017-10-27 22:31:21 -0400
committerPhilip Sequeira2017-10-27 22:31:21 -0400
commit26af1fc9fb7b1437049119b1019a1c9c45634df9 (patch)
tree95365a80c48cab95c9685f00fe095307cf87675f
parenta23d832a7d620e54d61f9e7012b8ff479255b473 (diff)
downloadaur-26af1fc9fb7b1437049119b1019a1c9c45634df9.tar.gz
allow building against upstream ffmpeg for now
Also apply a patch for the issue that caused this mess. See the comments on the AUR page for some links to what's going on. This is a temporary situation until things settle down. I'm not sure what I'll do if mpv continues to reject upstream ffmpeg long-term, but I probably won't be continuing to carry these patches.
-rw-r--r--.SRCINFO7
-rw-r--r--5033.patch26
-rw-r--r--PKGBUILD9
3 files changed, 39 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8f20a775000..e707b4cd2ea3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Oct 15 20:22:44 UTC 2017
+# Sat Oct 28 02:30:42 UTC 2017
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.27.0_236_g6d534138ed
+ pkgver = 0.27.0_310_ga00a2266a0
pkgrel = 1
url = https://mpv.io
install = mpv.install
@@ -20,10 +20,13 @@ pkgbase = mpv-git
conflicts = mpv
options = !emptydirs
source = git+https://github.com/mpv-player/mpv
+ source = 5033.patch
source = find-deps.py
md5sums = SKIP
+ md5sums = 2292f053f7e2e5a32fcf778746c25265
md5sums = ffb774b13decbefc62908dda0332046b
sha256sums = SKIP
+ sha256sums = 8d46d9ba280a48248f28feeb3d2ff28a16dbd0a5eea8d9178756590de9e3e421
sha256sums = ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02
pkgname = mpv-git
diff --git a/5033.patch b/5033.patch
new file mode 100644
index 000000000000..b0db55ba6c8b
--- /dev/null
+++ b/5033.patch
@@ -0,0 +1,26 @@
+From 2b330cc60e1841f18512a99b52e25732725b886f Mon Sep 17 00:00:00 2001
+From: Daniel Kucera <daniel.kucera@gmail.com>
+Date: Mon, 23 Oct 2017 15:29:17 +0200
+Subject: [PATCH] demux_lavf: return AVERROR_EOF on file end
+
+Signed-off-by: Daniel Kucera <daniel.kucera@gmail.com>
+---
+ demux/demux_lavf.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/demux/demux_lavf.c b/demux/demux_lavf.c
+index 53bf62016a..214e0c297f 100644
+--- a/demux/demux_lavf.c
++++ b/demux/demux_lavf.c
+@@ -242,7 +242,10 @@ static int mp_read(void *opaque, uint8_t *buf, int size)
+
+ MP_TRACE(demuxer, "%d=mp_read(%p, %p, %d), pos: %"PRId64", eof:%d\n",
+ ret, stream, buf, size, stream_tell(stream), stream->eof);
+- return ret;
++ if (stream->eof)
++ return AVERROR_EOF;
++ else
++ return ret;
+ }
+
+ static int64_t mp_seek(void *opaque, int64_t pos, int whence)
diff --git a/PKGBUILD b/PKGBUILD
index dd18c6359d2e..e30790bff638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.27.0_236_g6d534138ed
+pkgver=0.27.0_310_ga00a2266a0
pkgrel=1
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -63,10 +63,13 @@ conflicts=('mpv')
options=('!emptydirs')
install=mpv.install
source=('git+https://github.com/mpv-player/mpv'
+ '5033.patch'
'find-deps.py')
md5sums=('SKIP'
+ '2292f053f7e2e5a32fcf778746c25265'
'ffb774b13decbefc62908dda0332046b')
sha256sums=('SKIP'
+ '8d46d9ba280a48248f28feeb3d2ff28a16dbd0a5eea8d9178756590de9e3e421'
'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02')
_opt_extra_flags=()
@@ -131,6 +134,10 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
./bootstrap.py
+
+ # Temporary workaround (see AUR comments)
+ git revert --no-edit 83d44aca7dc7f46b8d3b64d441f5a8317a40e080
+ git am "$srcdir/5033.patch"
}
build() {