summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2018-08-19 17:40:54 -0400
committerPhilip Sequeira2018-08-19 17:40:54 -0400
commitb6fdb9a48272329df2f5cf09dd07a9c2d16d8df7 (patch)
tree89b0648b4d914aebf466f6ef1c21d98e4a936338
parentb83c5010667e6dc91e1ef96ad4a26b3b10f9a044 (diff)
downloadaur-b6fdb9a48272329df2f5cf09dd07a9c2d16d8df7.tar.gz
find-deps: use direct path for python
This is always expected to be running on Arch or similarly configured systems so we know exactly where the system's Python is going to be, and that's the one we want to use. No need to risk problems from e.g. custom builds ahead of it in the path.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xfind-deps.py2
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 536e425e5bef..d05e64664ef6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 14 03:23:15 UTC 2018
+# Sun Aug 19 21:39:45 UTC 2018
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.29.0_19_g6c2d6a3046
+ pkgver = 0.29.0_21_gd2d7dba6ee
pkgrel = 1
url = https://mpv.io
install = mpv.install
@@ -24,7 +24,7 @@ pkgbase = mpv-git
source = find-deps.py
source = https://waf.io/waf-2.0.9
sha256sums = SKIP
- sha256sums = ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02
+ sha256sums = 1ba780ede4a28b68ae5b7ab839958ff91ed01d3c6c1d24cce8a5dd24492f8d2b
sha256sums = 2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48
pkgname = mpv-git
diff --git a/PKGBUILD b/PKGBUILD
index 004787e8f353..b64a6a4718be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.29.0_19_g6c2d6a3046
+pkgver=0.29.0_21_gd2d7dba6ee
pkgrel=1
_waf_version=2.0.9
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
@@ -67,7 +67,7 @@ source=('git+https://github.com/mpv-player/mpv'
'find-deps.py'
"https://waf.io/waf-${_waf_version}")
sha256sums=('SKIP'
- 'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02'
+ '1ba780ede4a28b68ae5b7ab839958ff91ed01d3c6c1d24cce8a5dd24492f8d2b'
'2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48')
# vulkan-icd-loader contains vulkan.pc, which makes mpv think it can build
diff --git a/find-deps.py b/find-deps.py
index d6761f0a40fd..6c137a19dfb0 100755
--- a/find-deps.py
+++ b/find-deps.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python3
+#!/usr/bin/python3
"""
Usage: find-deps.py <binary> [<binary> ...]