summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkatsuki Rui2021-10-27 18:21:42 +0000
committerAkatsuki Rui2021-10-27 18:21:42 +0000
commitda0fdf99c4efb9885569c574a3ee8e1c31d978ee (patch)
tree6472ae06e082688896ffb24a0637541ea9d98c64
parent377ab3ad6fe88ec2f46835ca9e48d67983f8d129 (diff)
downloadaur-da0fdf99c4efb9885569c574a3ee8e1c31d978ee.tar.gz
0.2.13.r0.g1ef30ab-2: add youtube-dl and yt-dlp as optdepends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--mpv-handler.install16
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9038c0bb4d68..a685537070cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = mpv-handler-git
pkgdesc = Play website videos and songs with mpv & youtube-dl.
pkgver = 0.2.13.r0.g1ef30ab
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/akiirui/mpv-handler/
+ install = mpv-handler.install
arch = x86_64
license = MIT
makedepends = cargo
makedepends = git
depends = mpv
- depends = youtube-dl
+ optdepends = youtube-dl: ytdl-hook support
+ optdepends = yt-dlp: alternatives ytdl-hook support
provides = mpv-handler
conflicts = mpv-handler
source = git+https://github.com/akiirui/mpv-handler.git
diff --git a/PKGBUILD b/PKGBUILD
index be441cde1193..a1f212c6e93d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,16 @@
_pkgname="mpv-handler"
pkgname="mpv-handler-git"
pkgver=0.2.13.r0.g1ef30ab
-pkgrel=1
+pkgrel=2
pkgdesc="Play website videos and songs with mpv & youtube-dl."
arch=("x86_64")
-depends=("mpv" "youtube-dl")
+depends=("mpv")
+optdepends=(
+ "youtube-dl: ytdl-hook support"
+ "yt-dlp: alternatives ytdl-hook support"
+)
makedepends=("cargo" "git")
+install="mpv-handler.install"
url="https://github.com/akiirui/mpv-handler/"
license=("MIT")
provides=("mpv-handler")
diff --git a/mpv-handler.install b/mpv-handler.install
new file mode 100644
index 000000000000..9962b680208b
--- /dev/null
+++ b/mpv-handler.install
@@ -0,0 +1,16 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+post_install() {
+ note "Don't forget install youtube-dl or yt-dlp for mpv ytdl-hook support"
+}
+
+post_upgrade() {
+ post_install
+}